HDOJ 2717 Catch That Cow

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12304    Accepted Submission(s): 3822


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 

Source
 

Recommend
teddy
 

用bfs历遍所有情况,找到正确的就退出。

应该是一个比较简单的题,怎么搜也很好想。

bfs原理我是明白的,不过我其实还不怎么明白具体代码的时候怎么把最小的情况挑出来……总之现在还算能做题,所以凑合着来吧……以后多做做题应该能更好地了解吧。


题意:FJ想尽快抓住他的牛,现在知道他和牛的位置,FJ有两种追赶方式,一种是向前或者向后一步,另一种是跳到目前的位置的二倍的地区。问:他追牛最快需要几分钟?


#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<algorithm>
using namespace std;
int map[1000000+10],n,k;
struct node
{
	int x,step;
}a,tmp;
int OK(int x)
{
	if(x<0||x>=1000000||map[x]==1)
		return 0;
	return 1;
}
int bfs(int x)
{
	int i;
	queue<node> q;
	a.x=x;a.step=0;map[x]=1;
	q.push(a);
	while(!q.empty())
	{
		a=q.front();
		q.pop();
		if(a.x==k)
			return a.step;
		tmp=a;
		tmp.x=a.x+1;
		if(OK(tmp.x))
		{
			tmp.step=a.step+1;
			map[tmp.x]=1;
			q.push(tmp);
		}
		tmp.x=a.x-1;
		if(OK(tmp.x))
		{
			tmp.step=a.step+1;
			map[tmp.x]=1;
			q.push(tmp);
		}
		tmp.x=a.x*2;
		if(OK(tmp.x))
		{
			tmp.step=a.step+1;
			map[tmp.x]=1;
			q.push(tmp);
		}
	}
	return -1;
}
int main()
{
	while(~scanf("%d%d",&n,&k))
	{
		memset(map,0,sizeof(map));
		int ans=bfs(n);
		printf("%d\n",ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值