POJ 1745 Divisibility

Divisibility
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11519 Accepted: 4127

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible

Source



题目大意就是有一串数字,每两个数字之间可以添加加号或者减号,现在给一个数字k,问最后那个数列能生成的所有值里面,有没有一个值可以被k恰好整除。可以的化就输出Divisible。

这个提用的方法好神奇!!!昨天做了两题都是利用二维数组的角标来dp,超神奇,超厉害。

这里开一个二维数组,角标分别表示加/减了这个数组里的多少个数,这么多数相加/减后和k相除的余数。具体怎么实施代码写的很清楚,就不一一分析了。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[10000+10][111];
int a[10000+10];
int fun(int n,int k)
{
	n=n%k;
	if(n<0)
		n+=k;
	return n;
} 
int main()
{
	int n,k,i,j;
	while(~scanf("%d%d",&n,&k))
	{
		memset(dp,0,sizeof(dp));
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		dp[1][fun(a[1],k)]=1;
		for(i=2;i<=n;i++)
		{
			for(j=0;j<k;j++)
			{
				if(dp[i-1][j])
				{
					dp[i][fun(j+a[i],k)]=1;
					dp[i][fun(j-a[i],k)]=1;
				}
			}
		}
		if(dp[n][0])
			printf("Divisible\n");
		else
			printf("Not divisible\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值