POJ 3070 —— Fibonacci 【矩阵快速幂】

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12190 Accepted: 8651

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

 

#include <cstdio>
#include <iostream>
#include <vector>
#include <assert.h>
using namespace std;

const int MOD = (int)1e4;

struct Mat {
    vector<vector<int> > m;
    Mat() {}
    Mat(int a, int b) {
        m.resize(a);
        for(int i=0; i<m.size(); i++) {
            m[i].resize(b);
        }
    }
};

Mat operator * (const Mat& a, const Mat& b) {
    assert(a.m[0].size() == b.m.size());
    Mat c(a.m.size(), b.m[0].size());
    for(int i=0; i<a.m.size(); i++) {
        for(int j=0; j<b.m[0].size(); j++) {
            c.m[i][j] = 0;
            for(int k=0; k<b.m.size(); k++) {
                c.m[i][j] = (c.m[i][j] + a.m[i][k] * b.m[k][j] % MOD) % MOD;
            }
        }
    }
    return c;
}

Mat operator ^ (Mat a, int k) {
    assert(a.m.size() == a.m[0].size());
    Mat c(a.m.size(), a.m.size());
    
    for(int i=0; i<a.m.size(); i++) {
        for(int j=0; j<a.m.size(); j++) {
            c.m[i][j] = (i==j);
        }
    }
    
    while(k) {
        if(k&1) {
            c = c * a;    
        }
        a = a * a;
        k>>=1;
    }
    return c;
}

int main ()
{
    int n;
    Mat a(2,2), b(2,1);
    a.m[0][0]=a.m[1][0]=a.m[0][1]=1;
    a.m[1][1]=0;
    
    b.m[0][0]=1;
    b.m[1][0]=0;
    
    while(scanf("%d", &n) != EOF && n != -1) {
        if(n==0)    printf("%d\n", b.m[1][0]);
        else if(n==1)    printf("%d\n", b.m[0][0]);
        else {
            Mat ans = (a^(n-1)) * b;
            printf("%d\n", ans.m[0][0]);
        }
    }
    
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值