31:B ·Nim-B* Sum

B ·Nim-B* Sum
NIM is an ambigram . The game of NIM is played with any number of piles of objects with any number of objects in each pile. At each turn, a player takes one or more (up to all) objects from one pile. In the normal form of the game, the player who takes the last object is the winner. There is a well-known strategy for this game based on the nim-2 sum. 
The Nim-B sum (nim sum base B) of two non-negative integers X and Y (written NimSum(B, X, Y)) is computed as follows:

1) Write each of X and Y in base B.
2) Each digit in base B of the Nim-B sum is the sum modulo B of the corresponding digits in the base B representation of X and Y.

For example:
NimSum(2, 123, 456) = 1111011 ¤ 111001000 = 110110011 = 435
NimSum(3, 123, 456) = 11120 ¤ 121220 = 102010 = 300
NimSum(4, 123, 456) = 1323 ¤ 13020 = 10303 = 307

The strategy for normal form Nim is to compute the Nim-2 sum T of the sizes of all piles. If at any time, you end your turn with T = 0, you are guaranteed a WIN. Any opponent move must leave T not 0 and there is always a move to get T back to 0. This is done by computing NimSum(2, T, PS)for each pile; if this is less than the pile size (PS), compute the difference between the PS and the Nim-2 sum and remove it from that pile as your next move.
Write a program to compute NimSum(B, X, Y).

Input
The first line of input contains a single integer P, (1 <= P <= 1000), which is the number of data sets that follow. Each data set is a single line that contains the data set number, followed by a space, followed by three space separated decimal integers, B, X and Y. 2 <= B <= 2000000, 0 <= X <= 2000000, 0 <= Y <= 2000000.

Output
For each data set there is one line of output. It contains the data set number followed by a single space, followed by N, the decimal representation of the Nim sum in base B of X and Y.

Sample Input
4
1 2 123 456
2 3 123 456
3 4 123 456
4 5 123 456

Sample Output
1 435
2 300
3 307
4 429


package OJ;

import java.util.*;

public class P31_temp {

	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		ArrayList<Integer> results = new ArrayList<Integer>();
		int caseNum = in.nextInt();
		for(int i=0; i<caseNum; i++){
			
			int order = in.nextInt();
			int base = in.nextInt();
			int digit1 = in.nextInt();
			int digit2 = in.nextInt();
			ArrayDeque<Integer> temp1 = new ArrayDeque<Integer>();
			ArrayDeque<Integer> temp2 = new ArrayDeque<Integer>();
			ArrayDeque<Integer> result = new ArrayDeque<Integer>();
			while(digit1 != 0){
				temp1.addFirst(digit1%base);
				digit1 = digit1/base;
			}
			while(digit2 != 0){
				temp2.addFirst(digit2%base);
				digit2 = digit2/base;
			}
			if(temp1.size() <= temp2.size()){
				while(temp2.size() >0){
					if(temp1.size() >0)
						result.addFirst((temp1.pollLast()+temp2.pollLast())%base);
					else
						result.addFirst(temp2.pollLast());
				}				
			}
			else{
				while(temp1.size() >0){
					if(temp2.size() >0)
						result.addFirst((temp1.pollLast()+temp2.pollLast())%base);
					else
						result.addFirst(temp1.pollLast());
				}
			}
			int finalresult = 0;
			int temp = 1;
			while(result.size() > 0){
				finalresult += (result.pollLast()*temp);
				temp = temp*base;
			}
			results.add(finalresult);
		}
		for(int k=0; k<results.size(); k++){
			int orderNum = k+1;
			System.out.println(orderNum + " " + results.get(k));
		}
	}

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值