九度OJ题目1004:Median

题目1004:Median

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:14289

解决:3919

题目描述:

    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the non-decreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.
    Given two increasing sequences of integers, you are asked to find their median.

输入:

    Each input file may contain more than one test case.
    Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤1000000) is the size of that sequence. Then N integers follow, separated by a space.
    It is guaranteed that all the integers are in the range of long int.

输出:

    For each test case you should output the median of the two given sequences in a line.

样例输入:
4 11 12 13 14
5 9 10 15 16 17
样例输出:
13
来源:
2011年浙江大学计算机及软件工程研究生机试真题
答疑:
解题遇到问题?分享解题心得?讨论本题请访问: http://t.jobdu.com/thread-7728-1-1.html

这道题,不需要复杂,其实最好的办法,就是二分法查找出中间值即可,但是那个办法留在查找一部分AC,这里我们用两种比较浪费的方式,一种是nlgn的排序办法,但是由于数据规模较小,仍被允许,第二种是归并排序,仍可接受。
值得注意是,在我们发现WA时,先不要着急,我们多试几组测试用例,自己设计极端情况,并且仔细读原题,耐心才是解决WA的关键,很多人做题时本机能运行,提交就WA,这种都是由于有些CASE过不了造成的,一定是程序还有问题。

#include<stdio.h>
#include<algorithm>
using namespace std;
int a[2000005];
int main()
{
        int n,m,i;
        while(scanf("%d",&n)!=EOF)
        {for(i=0;i<n;i++) scanf("%d",&a[i]);
        scanf("%d",&m);
        for(i=n;i<n+m;i++) scanf("%d",&a[i]);
        sort(a,a+n+m);
        printf("%d\n",a[(m+n-1)/2]);}
        return 0;
}


#include <stdio.h>
#include <algorithm>
 
using namespace std;
int arr1[1000010];
int arr2[1000010];
int arr3[1000010];
int main()
{
    int n,m;
    int i,j,k;
    while(scanf("%d",&n)!=EOF)
    {
        for( i=0;i<n;i++)
            scanf("%d",&arr1[i]);
        sort(arr1,arr1+n);
        scanf("%d",&m);
        for( i=0;i<m;i++)
            scanf("%d",&arr2[i]);
        sort(arr2,arr2+m);
        i=0;
        j=0;
        k=0;
        while(i<n&&j<m)
        {
            if(arr1[i]<arr2[j])
                arr3[k++]=arr1[i++];
            else
                arr3[k++]=arr2[j++];
        }
        while(i<n)arr3[k++]=arr1[i++];
        while(j<m)arr3[k++]=arr2[j++];
        printf("%d\n",arr3[(k-1)/2] );
    }
    return 0;
}

当然啦,最好的办法还是由有序序列这一性质导致的二分查找方法,此法见查找部分。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值