Minimum Transport Cost

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and 

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities. 

You must write a program to find the route which has the minimum cost. 

Input

First is N, number of cities. N = 0 indicates the end of input. 

The data of path cost, city tax, source and destination cities are given in the input, which is of the form: 

a11 a12 ... a1N 
a21 a22 ... a2N 
............... 
aN1 aN2 ... aNN 
b1 b2 ... bN 

c d 
e f 
... 
g h 

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form: 

Output

From c to d : 
Path: c-->c1-->......-->ck-->d 
Total cost : ...... 
...... 

From e to f : 
Path: e-->e1-->..........-->ek-->f 
Total cost : ...... 

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case. 
 

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

题意:第一行给出一个n,代表有n个城市,接下来n行n列代表从i城市到j城市的费用,第n+2行的n个数代表经过经过这n个城市的税收,然后接下来每行两个数a,b,问从a到b的最小花费(包括税收),并且输出路径,输出参照样例.

注意:这个题要求当最短路不唯一时,输出字典序最小的方案。

思路:这个题是最短路径问题,但是要记录一个路径,由于n没有给出范围,可以尝试用一下弗洛里得算法,在该算法中三层for循环,k是中转点,i是起点,j是终点,如果从 i 到 k 再到 j 比直接从 i 到 j 小,那么可以通过 k 进行一个中转,同时记录一下这个中转点k,怎末记录呢?这里用一个数组path我们可以先让path【i】【j】均初始化为j表示初始状态下不需要中转,然后从i到j如果需要k中转的话就让path【i】【j】=path【i】【k】,path数组的作用就是记录一下当前城市前面中转的城市,最后注意一下输出,另外当中转和不中转相等的情况下要取一个最小的。代码如下: 

#include<stdio.h>
#include<string.h>  //总费用最低
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
int N;
int e[100][100],a[100],path[100][100];
void angel()
{
    int i,j,k;
    for(k=1;k<=N;k++)   //中专点
    {
        for(i=1;i<=N;i++) //起点
        {
            for(j=1;j<=N;j++)//终点
            {
                if(a[k]+e[i][k]+e[k][j]<e[i][j])
                {
                    e[i][j]=a[k]+e[i][k]+e[k][j];  //path数组作用是找到当前城市前面的一个中转城市
                    path[i][j]=path[i][k];  //从i到j要经过k城市中转,j城市前有一个k城市
                }
                else if(a[k]+e[i][k]+e[k][j]==e[i][j])
                {
                    path[i][j]=min(path[i][j],path[i][k]); //输出字典序最小的路径
                }
            }
        }
    }
}
int main()
{
    int i,j,s,t;
    while(~scanf("%d",&N)&&N)
    {
        memset(e,0,sizeof(e));
        for(i=1;i<=N;i++)
        {
            for(j=1;j<=N;j++)
            {
                path[i][j]=j;
                scanf("%d",&e[i][j]);
                if(e[i][j]==-1)
                    e[i][j]=inf;
            }
        }
        for(i=1;i<=N;i++)
            scanf("%d",&a[i]);
        while(~scanf("%d %d",&s,&t)&&(s!=-1||t!=-1))
        {
            angel();
            printf("From %d to %d :\n",s,t);
            printf("Path: %d",s);
            int ss=s;
            while(ss!=t)
            {
                printf("-->%d",path[ss][t]);
                ss=path[ss][t];
            }
            printf("\n");
            printf("Total cost : %d\n\n",e[s][t]);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值