[洛谷]P2255 [USACO14JAN]记录奥林比克 (#贪心)

42 篇文章 0 订阅
36 篇文章 0 订阅

题目描述

Being a fan of all cold-weather sports (especially those involving cows),Farmer John wants to record as much of the upcoming winter Moolympics as possible.

The television schedule for the Moolympics consists of N different programs(1 <= N <= 150), each with a designated starting time and ending time. FJ has a dual-tuner recorder that can record two programs simultaneously.

Please help him determine the maximum number of programs he can record in total.

农民约翰热衷于所有寒冷天气的运动(尤其是涉及到牛的运动), 农民约翰想录下尽可能多的电视节目。 为moolympics电视时间表由N个不同的节目 (1 < = n=150),每个具有指定的开始时间和结束时间。FJ 有一个双调谐器录音机,可以同时录制两个节目。 请帮助他确定他能录制的节目的最大数量。

输入输出格式

输入格式:

* Line 1: The integer N.

* Lines 2..1+N: Each line contains the start and end time of a single program (integers in the range 0..1,000,000,000).

第1行:整数n。 第2行.. 1 + n:每行包含单个的开始和结束时间 程序(范围为0…1000000000的整数)。

输出格式:

* Line 1: The maximum number of programs FJ can record.

仅一行,节目FJ可以记录的最大数量。

输入输出样例

输入样例#1

6
0 3
6 7
3 10
1 5
2 8
1 9

输出样例#1

4

说明

INPUT DETAILS:

The Moolympics broadcast consists of 6 programs. The first runs from time 0 to time 3, and so on.

OUTPUT DETAILS:

FJ can record at most 4 programs. For example, he can record programs 1 and 3 back-to-back on the first tuner, and programs 2 and 4 on the second tuner.

Source: USACO 2014 January Contest, Silver


思路

洛谷:

我们在每次调用摄像机2号时,鲁棒的交换摄像机1和摄像机2。

因为交换过后优先级较高的永远是最后拍摄的摄像机

我们就可以将它转换为一个只有一台摄像机的问题

而使用另一台摄像机只是开挂了,删除了一个任务。

#include <stdio.h>
#include <iostream>
#include <algorithm>
using namespace std;
struct lxydl
{
	int st,ed;
	friend bool operator <(lxydl a,lxydl b)
	{
		if(a.ed==b.ed) return a.st>b.st;
		return a.ed<b.ed;
	}
}a[201];
int n,s1(-1),s2(-1),cnt;
signed main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	cout.tie(0);
	register int i,j,k;
	cin>>n;
	for(i=1;i<=n;i++)
	{
		cin>>a[i].st>>a[i].ed;
	}
	sort(a+1,a+n+1);//按节省时间排序 
	for(i=1;i<=n;i++)
	{
		if(s1<=a[i].st)//第1摄像机优先级高 
		{
			cnt++;
			s1=a[i].ed;
		}
		else if(s2<=a[i].st)
		{
			cnt++;
			s2=a[i].ed;
			swap(s1,s2);//交换优先级 
		}
	}
	cout<<cnt<<endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值