POJ 3267 The Cow Lexicon


The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9759 Accepted: 4678

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively:  W and  L 
Line 2:  L characters (followed by a newline, of course): the received message 
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top



  这个题半天没读懂,看了半天评论后大概是这么个意思:第一行输入一个长度为L的字母串,剩下的W行为W个字典单词,然后让字符串与每一个字典单词进行匹配,问字符串最少需要删除的字母的个数。这道题就是DP+字符串匹配了,动态转移方程如下:


动态转移方程:    DP[i]=DP[i+1]+1;(没有满足匹配的单词)

           DP[i]=min(DP[i],DP[pm]+(pm-i)+len);(有满足匹配的单词)


   DP[i]表示的是message[i]到message[len-1]的满足的最小出去字母的个数,如果字典单词中没有能够匹配的,DP[i]直接等于DP[i+1]+1 ;如果存在能够匹配的单词,DP[i]=min(DP[i],DP[pm]+(pm-i)+len),这个就拿第一个为例:


  message: browndcodw      ----->       browndcodw      


              dir[0]: cow                                              co   w


此时pm(message的指针)数值为10,pd(dir的指针)数值为3,这期间没有匹配的字母(这里就为d)的个数为(pm-i)+len(i为message初始指针初始位置),加上第pm之后需要删除的最小值(这里是dp[10],数值为零)总的就为 DP[i]=min(DP[i],DP[pm]+(pm-i)+len);


//880K 329MS
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[300+5];
int main()
{
    char message[300+5], dir[600+5][300+5];
    int w, l;
    cin>>w>>l;
    cin>>message;
    for(int i=0;i<w;i++)
        cin>>dir[i];
    dp[l]=0;
    for(int i=l-1;i>=0;i--) {
        dp[i]=dp[i+1]+1;
        for(int j=0;j<w;j++) {
            int pm=i, pd=0;
            int len=strlen(dir[j]);
            if(len<=l-i) {
                while(pm<l) {
                    if(message[pm++]==dir[j][pd])
                        pd++;
                    if(pd==len) {cout<<i<<' '<<j<<' '<<pm<<' '<<i<<' '<<len<<endl;dp[i]=min(dp[i],dp[pm]+(pm-i)-len);break;}
                }
            }
        }
    }
    cout<<dp[0]<<endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值