Catch That Cow --简单的bfs

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

这个是一个简单的bfs

用step[maxn]来记录步数,刚开始初始化step,全为-1,表示没有走过该点。初始点的步数赋值为0.每次进行判断,为-1表示没有走过,遍历该点。

#include<iostream>
#include<queue>
#include<algorithm>
#include<cstring>
using namespace std;
const int inf=-1;
const int maxn=100005;
int N,K;
int step[maxn];//记录步数 

void bfs(int n,int k)
{
	queue<int> q;
	memset(step,inf,sizeof(step));
	step[n]=0;
	q.push(n);
	while(!q.empty())
	{
		int v=q.front();
		q.pop();
		if(v==k)
		{
			return;
		}
		if(v-1>=0&&step[v-1]==inf)
		{
			q.push(v-1);
			step[v-1]=step[v]+1;
		}
		if(v+1<=maxn&&step[v+1]==inf)
		{
			q.push(v+1);
			step[v+1]=step[v]+1;
		}
		if(2*v<=maxn&&step[2*v]==inf)
		{
			q.push(2*v);
			step[2*v]=step[v]+1;
		}
	}
	
}

int main()
{
	cin>>N>>K;
	bfs(N,K);
	cout<<step[K]<<endl;
	return 0; 
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值