1018: Give me the answer

1018: Give me the answer

时间限制: 1 Sec  内存限制: 32 MB
提交: 55  解决: 15
[提交][状态][讨论版][命题人:外部导入]

题目描述

Farmer John commanded his cows to search for different sets of numbers that sum to a given number.
The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that
sum to 7:
1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4
Help FJ count all possible representations for a given integer N (1 <= N <= 1 ,000,000)

 

输入

The first line of the input contains the number of test cases in the file. And t he first line of each case
contains one integer numbers n

 

输出

For each test case, output a line with the ans % 1000000000.

 

样例输入

1
7

样例输出

6

#include<stdio.h>
#define MAX 1000010
int a[MAX];
int main()
{
    int n, m, i;
    a[1] = 1;
    a[2] = 2;
    for(i = 3; i <= MAX; ++i)
    {
        if(i & 1)
            a[i] = a[i - 1] % 1000000000;
        else
            a[i] = (a[i - 1] + a[i / 2]) % 1000000000;
    }
    scanf("%d", &n);
    while(n--)
    {
        scanf("%d", &m);
        printf("%d\n", a[m]);
    }
    return 0;
}

  

 

转载于:https://www.cnblogs.com/mjn1/p/9937017.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值