Leading and Trailing 快速幂和cmath函数(modf函数,log10函数,pow函数)

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output
For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input
5
123456 1
123456 2
2 31
2 32
29 8751919
Sample Output
Case 1: 123 456
Case 2: 152 936
Case 3: 214 648
Case 4: 429 296

Case 5: 665 669

题意:

很好理解,就是求一个数的前三位和最后三位。

后三位好求,快速幂mod=1000,结果就是后三位。

前三位用modf函数求x=lg(n^k)的小数部分,然后10^x*100就是前三位,也就是ans=10^(x+2);

还要注意一点,最后三位前两位可能有0,如003,这时用%03lld,(设定长度为三,不足用0填充),输出就为003,而不是3。

#include<cstdio>
#include<cmath>
using namespace std;
typedef long long ll;
const int mod=1000;

ll powmod(ll x,ll n)
{
    if(n==0) return 1%mod;
    ll temp=powmod(x,n>>1);
    temp=temp*temp%mod;
    if(n&1) temp=temp*x%mod;
    return temp;
}

int main()
{
    int t;
    ll n,k;
    scanf("%d",&t);
    for(int i=1;i<=t;++i)
    {
        double intpart;
        scanf("%lld%lld",&n,&k);
        int ans=(int)pow(10.0, 2.0 + modf((double)k * log10(n), &intpart));
        printf("Case %d: %d %03lld\n",i,ans,powmod(n,k));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值