【bzoj4742: [Usaco2016 Dec]Team Building】dp

4742: [Usaco2016 Dec]Team Building

Time Limit: 10 Sec   Memory Limit: 128 MB
Submit: 168   Solved: 98
[ Submit][ Status][ Discuss]

Description

Every year, Farmer John brings his NN cows to compete for "best in show" at the state fair. His arch
-rival, Farmer Paul, brings his MM cows to compete as well (1≤N≤1000,1≤M≤1000).Each of the N+MN+
M cows at the event receive an individual integer score. However, the final competition this year wi
ll be determined based on teams of KK cows (1≤K≤10), as follows: Farmer John and Farmer Paul both 
select teams of KK of their respective cows to compete. The cows on these two teams are then paired 
off: the highest-scoring cow on FJ's team is paired with the highest-scoring cow on FP's team, the s
econd-highest-scoring cow on FJ's team is paired with the second-highest-scoring cow on FP's team, a
nd so on. FJ wins if in each of these pairs, his cow has the higher score.Please help FJ count the n
umber of different ways he and FP can choose their teams such that FJ will win the contest. That is,
 each distinct pair (set of KK cows for FJ, set of KK cows for FP) where FJ wins should be counted. 
Print your answer modulo 1,000,000,009.
每年农夫约翰都会带着他的N只牛去集会上参加“你是最棒哒“的比赛。他的对手农夫保罗也带了M只牛去参加比赛
(1 ≤ N ≤ 1000, 1 ≤ M ≤ 1000)。每只牛都有自己的分数。两人会选择K只牛组成队伍(1 ≤ K ≤ 10),两队
牛在按分数大小排序后一一配对,并且约翰打败保罗当且仅当对于每一对牛,约翰的牛分数都比保罗的高。请帮助
约翰计算约翰打败保罗的方案数 mod 1000000009。两种方案不同,当且仅当约翰或保罗选择的牛的集合与另一种
方案不同。

Input

The first line of input contains N, M, and K. The value of K will be no larger than N or M.
The next line contains the N scores of FJ's cows.
The final line contains the M scores of FP's cows.

Output

Print the number of ways FJ and FP can pick teams such that FJ wins, modulo 1,000,000,009.

Sample Input

10 10 3
1 2 2 6 6 7 8 9 14 17
1 3 8 10 10 16 16 18 19 19

Sample Output

382


约翰的牛为a[i]   保罗的牛为b[i]

记f[i][j][k]=约翰的前i头牛与保罗前j头牛各选k头出来比时,约翰打败保罗的方案数

可以得到状态转移方程:

f[i][j][k]=f[i-1][j][k]+f[i][j-1][k]-f[i-1][j-1][k]+f[i-1][j-1][k-1]*(a[i]>b[j]);

因为f[i-1][j][k]+f[i][j-1][k]-f[i-1][j-1][k]是假设a[i]必选或者b[j]必选的方案数,若a[i]>b[j],则可以让前i-1,j-1头牛取k-1对比较,最后取a[i]和b[j],一共构成k对获胜的方案数。

(我加了个排序 ,应该是不用的)

#include<cstdio>
#include<algorithm>
#include<iostream>
#define MOD 1000000009
#define N 1050
using namespace std;
int n,m,k,a[N],b[N];
long long f[N][N][11];
bool cmp(int a,int b){
	return a>b;
}
int main(){
	scanf("%d%d%d",&n,&m,&k);
	for(int i=1;i<=n;i++) scanf("%d",&a[i]);
	for(int i=1;i<=m;i++) scanf("%d",&b[i]);
	sort(a+1,a+1+n,cmp);
	sort(b+1,b+1+m,cmp);
	for(int i=0;i<=n;i++)for(int j=0;j<=m;j++) f[i][j][0]=1;
	for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
			for(int p=1;p<=min(k,min(i,j));p++)
				f[i][j][p]=(MOD+f[i-1][j][p]+f[i][j-1][p]-f[i-1][j-1][p]+(a[i]>b[j])*f[i-1][j-1][p-1])%MOD;
	printf("%d\n",f[n][m][k]);
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值