HDU 2608 0 or 1

0 or 1
Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3708 Accepted Submission(s): 1077

Problem Description
Solving problem is a interesting thing. Yifenfei like to slove different problem,because he think it is a way let him more intelligent. But as we know,yifenfei is weak in math. When he come up against a difficult math problem, he always try to get a hand. Now the problem is coming! Let we
define T(n) as the sum of all numbers which are positive integers can divied n. and S(n) = T(1) + T(2) + T(3)…..+T(n).

Input
The first line of the input contains an integer T which means the number of test cases. Then T lines follow, each line consists of only one positive integers n. You may assume the integer will not exceed 2^31.

Output
For each test case, you should output one lines of one integer S(n) %2. So you may see the answer is always 0 or 1 .

Sample Input
3
1
2
3

Sample Output
1
0
0

Hint
Hint S(3) = T(1) + T(2) +T(3) = 1 + (1+2) + (1+3) = 8
S(3) % 2 = 0

Author
yifenfei

题目意思不就是分别求下T[i],然后再对T[i]求和,求其s%2的值,这个数据量蛮大的,一遍遍过去肯定是要超时的,然后找规律啊,发现这个s竟然是i* i<= x和2* i* i<=x的个数,其实反向求也是正确的,毕竟只有0和1,我是想不出来他们怎么0ms通过的,可能打表吧,处理一下,数据量大访问就可以了,不浪费多少时间的,存完全平方数,2^31大概是2^15的平方,其实也就1024*32,我想了想处理sqrt用了二分什么的发现没有卵用,恐怕他们用的就是打表了省时间

#include <stdio.h> 
int main(  )
{  
    int T;
    scanf( "%d", &T );
    while( T-- )
    {
        long long x;
        int n=-1;
        scanf( "%lld", &x );
        for( long long i= 1; i* i<= x; ++i )
        {
            if( 2* i* i>x )
            n=-n;
        }
        printf("%d\n",n==1?1:0);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值