POJ 2387 Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90
 
 
题意很简单就是求1到N的最短路。
N<=1000所以不能用Floyd,其他的随意,这里注意一点就是有可能会有重复的点,所以要判断一下。
Dijkstra
  
  
StatusAccepted
Time63ms
Memory4080kB
Length897
LangC++
Submitted
Shared
RemoteRunId18038947
#include <stdio.h>
#define inf 0x3f3f3f3f
int e[1005][1005];
int dis[1005];
int book[1005];
void init(int n) {
	for(int i = 0; i <= n; i++) {
		for(int j = 0; j <= n; j++) {
			if(i == j) e[i][j] = 0;
			else e[i][j] = inf;
		}
	}
	for(int i = 1; i <= n; i++) {
		book[i] = 0;
	}
}
int main() {
	int T, N, mn;
	int t1, t2, v;
	scanf("%d %d",&T, &N);
	init(N);
	for(int i = 0; i < T; i++) {
		scanf("%d %d %d", &t1, &t2, &v);
		if(e[t1][t2] <= v) continue;//判断是否会有重复的点 
		e[t1][t2] = v;
		e[t2][t1] = v;
	}
	for(int i = 1; i <= N; i++) dis[i] = e[1][i];
	book[1] = 1;
	int u;
	for(int i = 1; i <= N-1; i++) {
		mn = inf;
		for(int j = 1; j <= N; j++) {
			if(book[j] == 0 && dis[j] < mn) {
				mn = dis[j];
				u = j;
			}
		}
		book[u] = 1;
		for(int k = 1; k <= N; k++) {
			if(e[u][k] < inf) {
				if(dis[k] > dis[u] + e[u][k]) 
				dis[k] = dis[u] + e[u][k];
			}
		}
	}
	printf("%d\n",dis[N]);
	return 0;
}
Bellman-Ford
  
  
Accepted
Time16ms
Memory164kB
Length559
LangC++
Submitted
Shared
RemoteRunId18038973
#include <stdio.h>
#define inf 0x3f3f3f3f
int u[2005];
int v[2005];
int w[2005];
int dis[2005];
void init(int n) {
	for(int i = 0; i <= n; i++) {
		dis[i] = inf;
	}
	dis[1] = 0;
}
int main() {
	int T, N;
	scanf("%d%d",&T, &N);
	init(N);
	for(int i = 1; i <= T; i++) {
		scanf("%d %d %d",&u[i], &v[i], &w[i]);
	}
	for(int k = 1; k <= N; k++) {
		for(int i = 1; i <= T; i++) {
			if(dis[v[i]] > dis[u[i]] + w[i])//写两个判断是否会有重复的点 
			dis[v[i]] = dis[u[i]] + w[i];
			if(dis[u[i]] > dis[v[i]] + w[i])
			dis[u[i]] = dis[v[i]] + w[i];			
		}
	}
	printf("%d\n",dis[N]);
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值