(HDU 4293) Groups (区间DP)

Groups

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1959    Accepted Submission(s): 774


Problem Description
  After the regional contest, all the ACMers are walking alone a very long avenue to the dining hall in groups. Groups can vary in size for kinds of reasons, which means, several players could walk together, forming a group.
  As the leader of the volunteers, you want to know where each player is. So you call every player on the road, and get the reply like “Well, there are A i players in front of our group, as well as B i players are following us.” from the i th player.
  You may assume that only N players walk in their way, and you get N information, one from each player.
  When you collected all the information, you found that you’re provided with wrong information. You would like to figure out, in the best situation, the number of people who provide correct information. By saying “the best situation” we mean as many people as possible are providing correct information.
 

 

Input
  There’re several test cases.
  In each test case, the first line contains a single integer N (1 <= N <= 500) denoting the number of players along the avenue. The following N lines specify the players. Each of them contains two integers A i and B i (0 <= A i,B i < N) separated by single spaces.
  Please process until EOF (End Of File).
 

 

Output
  For each test case your program should output a single integer M, the maximum number of players providing correct information.
 

 

Sample Input
3 2 0 0 2 2 2 3 2 0 0 2 2 2
 

 

Sample Output
2 2
 
F**K这道奇葩的题真是坑了我好半天。
思路真的是好奇特。
因为一个团体中的人数是不确定的,用一个二维数组表示【i, j】作为一个团体时,当中有多少人了说真话。
输入时可以直接特判某些情况的错误,最后用一个一维dp解出从0到i最多几人说了真话,dp【n】就是答案
 
#include<iostream>
#include<cstdio>
#include<vector>
#include<set>
#include<map>
#include<string.h>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#define LL long long
#define mod 1000000007
#define inf 0x3f3f3f3f

using namespace std;

int dp[510][510];

int main()
{
    int n;
   while(~scanf("%d",&n))
   {
       memset(dp,0,sizeof(dp));
       for(int i=1;i<=n;i++)
       {
           int a,b;
           scanf("%d%d",&a,&b);
           if(dp[a+1][n-b]<n-b-a&&a+b+1<=n)
            dp[a+1][n-b]++;
       }
       int a[510]={0};
       for(int j=1;j<=n;j++)
        for(int i=0;i<j;i++)
            {
                a[j]=max(a[j],a[i]+dp[i+1][j]);
            }
        printf("%d\n",a[n]);
   }
   return 0;
}

 

 

转载于:https://www.cnblogs.com/brotherHaiNo1/p/8525955.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值