Questionnaire

Questionnaire

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 742    Accepted Submission(s): 509
Special Judge

Problem Description
In order to get better results in official ACM/ICPC contests, the team leader comes up with a questionnaire. He asked everyone in the team whether to have more training.



Picture from Wikimedia Commons


Obviously many people don't want more training, so the clever leader didn't write down their words such as ''Yes'' or ''No''. Instead, he let everyone choose a positive integer ai to represent his opinion. When finished, the leader will choose a pair of positive interges m(m>1) and k(0k<m) , and regard those people whose number is exactly k modulo m as ''Yes'', while others as ''No''. If the number of ''Yes'' is not less than ''No'', the leader can have chance to offer more training.

Please help the team leader to find such pair of m and k .
 

Input
The first line of the input contains an integer T(1T15) , denoting the number of test cases.

In each test case, there is an integer n(3n100000) in the first line, denoting the number of people in the ACM/ICPC team.

In the next line, there are n distinct integers a1,a2,...,an(1ai109) , denoting the number that each person chosen.
 

Output
For each test case, print a single line containing two integers m and k , if there are multiple solutions, print any of them.
 

Sample Input
  
  
1 6 23 3 18 8 13 9
 

Sample Output
  
  
5 3
 

题意:

     给定n个数,找出一对数m,k,使得这n个数模上m等于k的个数大于等于模上m不等于k的个数。若有多组m,k符合题意,仅输出一组m,k即可。


思路:

     一开始想的是找到这n个数中最大的数,遍历从2到这个数,找到符合题意的m,然后再优化,后来发现题目有更简单的做法。关键在于如果有多组m,k符合题意,仅输出一组即可。由题目可得,我们需找到一组m,k,然后把数组分成两部分,一部分是模m等于k的,一部分是模m不等于k的。我们不必求哪一组m,k使得结果最大,只需求一组符合题意的m,k即可。假设我们找到了一个数m,然后我们就要从余数1,2,3…m-1中找出一个符合题意的k,比较余数为k和其他余数所对应的个数是否符合题意,这样就把余数分为两个部分,k,和k之外的。由此我们可以想到,任何数除以2余数都只有两种情况,0或1,再加上此题不求最大,而且只求一组数,所以我们可以得出所有的例子都可以取到m=2,只需要看k=0和k=1时谁对应的数最大即可。由此题目简化。


下面贴上代码:

#include<cstdio>
using namespace std;

const int maxn=1e5+10;
int a[maxn];

int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int num=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            if(a[i]%2==1)
                num++;
        }
        if(num>=n-num)
            printf("2 1\n");
        else
            printf("2 0\n");
    }
    return 0;
}



智慧问卷是一种收集数据和统计信息的工具。它可以用来调查人们的意见、态度、行为等信息。智慧问卷的设计应该考虑到准确性、有效性和可靠性。 首先,智慧问卷的设计应该具有准确性。问卷应该明确表达问题,避免使用模糊的措辞或含糊不清的问题。问题的选项应该全面,可以覆盖受访者的各种可能答案。此外,问题的顺序应该逻辑合理,不要出现冗余或重复的问题。准确的设计可以确保采集到真实和可靠的数据。 其次,智慧问卷的设计应该具有有效性。问卷应该包含有针对性的问题,能够准确反映研究对象的需求和目的。问题的选项应该具有明确的分类和量化标准,以便于数据的分析和比较。此外,问卷的长度应该适中,不要太长或太短,以免影响受访者的回答质量。有效的设计可以提高问卷回复率和数据质量。 最后,智慧问卷的设计应该具有可靠性。问卷的内部一致性应该得到保证,即不同问题之间应该相互协调和补充。此外,问卷应该经过试用和修订,确保其在实际调查中能够得到正确和一致的回答。可靠的设计可以增加问卷的信度和可比性。 总而言之,智慧问卷的设计需要考虑准确性、有效性和可靠性。只有在这些方面都得到充分的考虑和实施的情况下,智慧问卷才能真正发挥其数据收集和统计信息的作用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值