A Mathematical Curiosity
转载自傻B园
Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
Sample Input
1 10 1 20 3 30 4 0 0
Sample Output
Case 1: 2 Case 2: 4 Case 3: 5
Source
Recommend
JGShining
作者
Michael
解题思路
这题是一个简单题,题目的大意是求给出的两个数n,m,求在0<a<b<m的这个区间,有多少组a,b满足(a^2+b^2 +m)/(ab)是一个整数,这个直接暴力枚举。要格外注意输入与输出。
#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int main()
{
int test,i,j,n,m,t=1;
scanf("%d",&test);
while(test--)
{
getchar();
t=1;
while(scanf("%d%d",&n,&m)&&n!=0||m!=0)
{
int sum=0;
for(i=1;i<n;i++)
{
for(j=i+1;j<n;j++)
{
if((i*i+j*j+m)%(i*j)==0)
{
sum++;
}
}
}
printf("Case %d: %d\n",t++,sum);
}
if(test>=1)
{
printf("\n");
}
}
return 0;
}