1075 PAT Judge (25 分)哈希表统计排序

题目

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.
Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4​​), the total number of users, K (≤5), the total number of problems, and M (≤10​5​​), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:
For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

解题思路

  题目大意: 有N个学生,K道题目,M个题目的提交信息,信息包含用户的id和题目的id和分数,统计每个学生的得分,并按规则排名——
  1. 总分降序排列;
  2. 如果总分相同,AC数目降序排列;
  3. 如果AC数目也相同,那么按照id升序排列;
  解题思路:   数据的规模是 1 0 5 10^5 105,时间却限制到了200ms,如果直接统计提交信息,不得不多重循环,把每道题目的信息统计到用户身上,那么时间复杂度大概率会大于 O ( n 2 ) O(n^2) O(n2),对于最后一个测试点,会超时。
  考虑用一个超大的数组users[N],运用数组随机访问的特性,减少数据查找归类的过程,把每次user_id的信息直接记录在users[user_id]上即可。同时注意,一次都没有通过的同学是不计入排名的。这样做的时间复杂度直接降到 O ( n ) O(n) O(n)

/*
** @Brief:No.1075 of PAT advanced level.
** @Author:Jason.Lee
** @Date:2019-01-23
** @Solution: Accepted!
*/
#include<iostream>
#include<vector>
#include<algorithm>

using namespace std;

struct user{
	int id;
	int score[6];
	int total;
	int perfect;
	bool neverPass;
};

user users[100000];

bool cmp(user&a,user&b){
	if(a.total!=b.total){
		return a.total>b.total;
	}else{
		if(a.perfect!=b.perfect) return a.perfect>b.perfect;
		else{
			return a.id<b.id;
		}
	}
}

int main(){
	int N,K,M;
	while(scanf("%d%d%d",&N,&K,&M)!=EOF){
		int score[6];
		user input{-1,{-1,-1,-1,-1,-1,-1},0,0,true};
		fill(users,users+100000,input);
		for(int i=0;i<K;i++)
			scanf("%d",&score[i]);
		int user_id,problem_id,score_obt;
		for(int i=0;i<M;i++){
			scanf("%d%d%d",&user_id,&problem_id,&score_obt);
			users[user_id].id = user_id;
			if(score_obt!=-1) users[user_id].neverPass = false;
			else score_obt = 0;
			users[user_id].score[problem_id] = max(score_obt,users[user_id].score[problem_id]);
		}
		vector<user> vu;
		for(int i=0;i<100000;i++){
			if(!users[i].neverPass){
				for(int j=1;j<=K;j++){
					if(users[i].score[j]!=-1){
						users[i].total+=users[i].score[j];
						if(users[i].score[j]==score[j-1]) users[i].perfect++;
					}
				}
				vu.push_back(users[i]);
			}
		}
		sort(vu.begin(),vu.end(),cmp);
		int rank = 1;
		int last = vu.size()-1;
		for(int i=0;i<last;i++){
			printf("%d %05d %d",rank,vu[i].id,vu[i].total);
			for(int j=1;j<=K;j++){
				if(vu[i].score[j]==-1) printf(" -");
				else printf(" %d",vu[i].score[j]);
			}
			printf("\n");
			if(vu[i].total!=vu[i+1].total) rank=i+2;
		} 
		printf("%d %05d %d",rank,vu[vu.size()-1].id,vu[last].total);
		for(int i=1;i<=K;i++){
			if(vu[last].score[i]==-1) printf(" -");
			else printf(" %d",vu[last].score[i]);
		}
		printf("\n");
	}
	return 0;
}

在这里插入图片描述

总结

  还是一道用空间换时间的题目,看提交结果,内存消耗都很大,时间却不一样。理清思路,直接统计排序即可,细心一点,不会有啥大问题。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值