L1-012 计算指数

文章提供C/C++、Java和Python的代码片段,演示如何用这些语言实现计算并输出给定正整数n的2^n值。
摘要由CSDN通过智能技术生成

真的没骗你,这道才是简单题 —— 对任意给定的不超过 10 的正整数 n,要求你输出 2n。不难吧?

输入格式:

输入在一行中给出一个不超过 10 的正整数 n。

输出格式:

在一行中按照格式 2^n = 计算结果 输出 2n 的值。

输入样例:

5

输出样例:

2^5 = 32

C:

#include<stdio.h>
#include<math.h>
int main()
{
	int n,s;
	scanf("%d",&n);
	s=pow(2,n);
	printf("2^%d = %d",n,s);
    return 0;
}

C++:

#include <iostream>
#include <cmath>
using namespace std;

int main() {
    int n, s;
    cin >> n;
    s = pow(2, n);
    cout << "2^" << n << " = " << s;
    return 0;
}

Java:

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        int n = scanner.nextInt();
        int s = (int) Math.pow(2, n);
        System.out.println("2^" + n + " = " + s);
    }
}

Python:

import math

n = int(input())
s = 2 ** n
print("2^{} = {}".format(n, s))

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

向阳而生__

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值