【PAT刷题甲级】1104.Sum of Number Segments

1104 Sum of Number Segments (20 分)

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10 ^5. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input

4
0.1 0.2 0.3 0.4

Sample Output

5.00

题意

计算连续子序列的和。用数学思想解即可。主要考查的是高精度计算。N比较大时,double类型的值多次累加导致的精度误差,在计算机的字长限制下会产生舍入误差。改成long double后即可通过。
double:%lf
long double:%Lf

long double和double的比较:
二者均为浮点数类型,区别如下:
(1) double类型为C++原始类型,所有编译器均支持,而long double是C99规范增加的新类型,只有支持C99的编译器才支持long double;
(2) 占用大小不同,double占8个字节,long double根据编译器实现不同,有占用8,10,12字节和16字节四种;
在long double用8字节实现时,long double 和double没有其它区别。对于其它实现方式,还有以下三项区别:
① 运算速度不同,long double占用字节多,运算速度会慢一些;
② 精度不同,long double可以表示更大的精度;
③ 表示范围不同,long double可以表示更大范围的浮点数。
来源:https://zhidao.baidu.com/question/1829941608365782620.html

代码

#include <iostream>
using namespace std;
int main(){
	int n;
	long double f,sum=0.0;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%Lf",&f);
		sum += f*(n-i)*(i+1);
	}
	printf("%.2Lf",sum);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值