hdu 1800 Flying to the Mars【水水】

链接:



Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8410    Accepted Submission(s): 2731


Problem Description

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed. 
 

Input
Input file contains multiple test cases. 
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 

Output
For each case, output the minimum number of broomsticks on a single line.
 

Sample Input
   
   
4 10 20 30 04 5 2 3 4 3 4
 

Sample Output
   
   
1 2
 

Author
PPF@JLU
 

Recommend
lcy
 



题意:

水题一枚,懒得写了

思路:

        就像 

hdu 1257 最少拦截系统【贪心 || DP——LIS】

一样,套用 “LIS”
      先把输入的序列按照从大到小排序,再看成是导弹拦截系统那题
      只是这里的导弹如果高度相同不可以拦截而已
      也就是把 “LIS” 的修改边界 >= 改成 >
      将总结的模板的 lower_bound 换成 upper_bound就可以了
      然后再输出 "LIS" 的长度


      后来听 lrbj 说了下,其实也没这么麻烦
      直接排序【我认为没有排序也可以】
      然后看哪个数字出现最多, 输出它的次数就好了
      lrbj AC 了, 我没试过, 想来是可以的
      因为多出来的人没有其他人可以教导, 就只有自己用一个扫把了

code:


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int maxn = 3000+10;
int a[maxn];
int h[maxn];

bool cmp(int a, int b)
{
    return a > b;
}

int main()
{
    int n;
    while(scanf("%d", &n) != EOF)
    {
        for(int i = 0; i < n; i++)
            scanf("%d", &a[i]);
        sort(a,a+n, cmp);
        h[0] = -1;
        h[1] = a[0];
        int len = 1;
        for(int i = 1; i < n; i++)
        {
            int index = upper_bound(h,h+len+1, a[i])-h; //“LIS”修改边界
            h[index] = a[i];
    //printf("test: h[%d] = %d\n", index, h[index]);
            if(index > len) len = index;
        }
        printf("%d\n", len);
        //for(int i = 0; i < n; i++) printf("%d ", h[i]); printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值