SDUT 2809 Goldbach

Goldbach

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

The Goldbach’s Conjecture is stated like the following:
Every even number greater than 4 can be written as the sum of two odd prime numbers.
Your task is now to verify Goldbach\'s Conjecture for all even numbers less than a million.

输入

The input contains multiple test cases. Each test case consisted of an even integer n with 6 < n < 1000000. Input will be terminated by 0.

输出

For every test case, print one line of the form “n = a + b”, a < b, without quotes. Where a and b are odd prime numbers. If there is more than one pair of odd primes, you are to print the pair a, b with the maximized difference b - a. If there are no such pair, print a line saying “Goldbach\'s conjecture is wrong.”.

示例输入

8
20
0

示例输出

8 = 3 + 5
20 = 3 + 17

#include <bits/stdc++.h>

using namespace std;

bool prim(int n)
{
    for(int i=2;i*i<=n;i++)
    {
        if(n%i == 0)
            return false;
    }
    return true;
}

int main()
{
    int n;
    while(cin>>n && n)
    {
        for(int i=2;i<=n/2;i++)
        {
            if(prim(i))
            {
                int t = n - i;
                if(prim(t))
                {
                    cout<<n<<" = "<<i<<" + "<<t<<endl;
                    break;
                }
            }
        }
    }
    return 0;






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值