SDUT 2132 数据结构实验之栈二:一般算术表达式转换成后缀式

            数据结构实验之栈二:一般算术表达式转换成后缀式

Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。
输入
输入一个算术表达式,以‘#’字符作为结束标志。
输出
输出该表达式转换所得到的后缀式。
示例输入

a*b+(c-d/e)*f#

示例输出

ab*cde/-f*+

#include <bits/stdc++.h>

using namespace std;

char s[1010];

int Judge(char ch)
{
    switch(ch)
    {
    case '+':
    case '-':
        return 1;
    case '*':
    case '/':
        return 2;
    default :
        return 3;
    }
}
int main()
{
    std::ios::sync_with_stdio(false);
    char ch;
    int top = 0;
    while(cin>>ch && ch != '#')
    {
        if(ch >= 'a' && ch <= 'z')
        {
            cout<<ch;
        }
        else if(ch != ')')
        {
            while(top && s[top] != '(' && Judge(s[top]) >= Judge(ch))
            {
                cout<<s[top];
                top--;
            }
            s[++top] = ch;
        }
        else
        {
            while(s[top] != '(')
            {
                cout<<s[top];
                top--;
            }
            top--;
        }
    }
    while(top)
    {
        cout<<s[top];
        top--;
    }
    cout<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值