HDU 5586

Sum

                        Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Problem Description
There is a number sequence  A1,A2....An ,you can select a interval [l,r] or not,all the numbers  Ai(lir)  will become  f(Ai) . f(x)=(1890x+143)mod10007 .After that,the sum of n numbers should be as much as possible.What is the maximum sum?
 
Input
There are multiple test cases.
First line of each case contains a single integer n. (1n105)
Next line contains n integers  A1,A2....An . (0Ai104)
It's guaranteed that  n106 .
 
Output
For each test case,output the answer in a line.
 
Sample Input
  
  
2 10000 9999 5 1 9999 1 9999 1
 
Sample Output
  
  
19999 22033
 
Source
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <vector>
#include <map>
#include <list>
#include <cmath>
#include <queue>
#include <stack>
#include <set>
#include <algorithm>
#define LL long long
#define INF 0x3f3f3f3f
#define RR freopen("in.txt","r",stdin)
#define WW freopen("out.txt","w",stdout)
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

using namespace std;

struct node
{
    int x;
    int fx;
}ls[100010];

int main()
{
    int n;
    while(~scanf("%d",&n) && n)
    {
        int sum = 0;
        int MAX = 0;
        int tmp = 0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&ls[i].x);
            sum += ls[i].x;
            ls[i].fx = (1890*ls[i].x+143) % 10007 - ls[i].x;
            tmp += ls[i].fx;
            tmp = tmp < 0 ? 0 : tmp;
            MAX = max(MAX,tmp);
        }
        printf("%d\n",MAX+sum);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值