Almost Union-Find(带删除并查集模板)

I hope you know the beautiful Union-Find structure. In this problem, you’re to implement something
similar, but not identical.
The data structure you need to write is also a collection of disjoint sets, supporting 3 operations:
1 p q Union the sets containing p and q. If p and q are already in the same set,
ignore this command.
2 p q Move p to the set containing q. If p and q are already in the same set,
ignore this command.
3 p Return the number of elements and the sum of elements in the set containing
p.
Initially, the collection contains n sets: {1}, {2}, {3}, . . . , {n}.
Input
There are several test cases. Each test case begins with a line containing two integers n and m
(1 ≤ n, m ≤ 100, 000), the number of integers, and the number of commands. Each of the next m lines
contains a command. For every operation, 1 ≤ p, q ≤ n. The input is terminated by end-of-file (EOF).
Output
For each type-3 command, output 2 integers: the number of elements and the sum of elements.
Explanation
Initially: {1}, {2}, {3}, {4}, {5}
Collection after operation 1 1 2: {1,2}, {3}, {4}, {5}
Collection after operation 2 3 4: {1,2}, {3,4}, {5} (we omit the empty set that is produced when
taking out 3 from {3})
Collection after operation 1 3 5: {1,2}, {3,4,5}
Collection after operation 2 4 1: {1,2,4}, {3,5}
Sample Input
5 7
1 1 2
2 3 4
1 3 5
3 4
2 4 1
3 4
3 3
Sample Output
3 12
3 7
2 8

题意:有n个数,刚开始每个数都是一个单独的集合里,给定下列三种操作

1 p q :将p 和 q 合并在一个集合里

2 p q :将p 放在 q所在的集合里

3 p : 输出p 所在的集合的元素个数和元素的和。
主要问题就是操作二:如果直接令p的父亲等于q的祖宗,那么与p相连的其他值就会跟着发生改变,因此这道题引进一个外壳数组使他们外壳相连,这样p的父亲值并不改变,让其外壳值等于q的祖宗即可
看代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAX=1e6+10;
int n,m,a,b,c,fx,fy;
int ke[MAX],cnt[MAX],f[MAX],sum[MAX];
void init() {
	for(int i=1; i<=n; i++) {
		sum[i]=f[i]=ke[i]=i;
		cnt[i]=1;
	}
}
int getf(int x) {
	return f[x]==x?x:f[x]=getf(f[x]);
}
void move() {
	cnt[fx]--;
	sum[fx]-=b;
	ke[b]=fy;//*****重点:只把外壳值改变,并不改变b的父亲值 
	sum[fy]+=b;
	cnt[fy]++;
}

void solve() {
	while(~scanf("%d %d",&n,&m)) {
		init();
		for(int i=1; i<=m; i++) {
			scanf("%d",&a);
			if(a==3) {
				scanf("%d",&b);
				fx=getf(ke[b]);
				printf("%d %d\n",cnt[fx],sum[fx]);
				continue;
			}
			scanf("%d %d",&b,&c);
			fx=getf(ke[b]);
			fy=getf(ke[c]);
			if(fx==fy)
				continue;
			if(a==1) {
				f[fx]=fy;
				cnt[fy]+=cnt[fx];
				sum[fy]+=sum[fx];
			}
			if(a==2)
				move();
		}
	}
}
int main() {
	solve();
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值