【CQOI2014】【BZOJ3505】数三角形

Description

给定一个nxm的网格,请计算三点都在格点上的三角形共有多少个。下图为4x4的网格上的一个三角形。

注意三角形的三点不能共线。

Input

输入一行,包含两个空格分隔的正整数m和n。

Output

输出一个正整数,为所求三角形数量。

Sample Input

2 2

Sample Output

76

数据范围

1<=m,n<=1000

HINT

Source

随随便便的组合+容斥.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define MAXN 2010
#define LL long long
using namespace std;
int n,m;
LL c[MAXN*MAXN][4];
LL ans;
int gcd(int a,int b)
{
    return !b?a:gcd(b,a%b);
}
int main()
{
    scanf("%d%d",&n,&m);n++;m++;c[0][0]=1;
    for (int i=1;i<=n*m;i++)
    {
        c[i][0]=1;
        for (int j=1;j<=3;j++)  c[i][j]=c[i-1][j-1]+c[i-1][j];
    }
    ans=c[n*m][3];ans-=m*c[n][3];ans-=n*c[m][3];
    for (int i=1;i<n;i++)
        for (int j=1;j<m;j++)
        {
            int tmp=gcd(i,j)+1;
            if (tmp>=3) ans-=(LL)(tmp-2)*(n-i)*(m-j)*2;
        }
    cout<<ans<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值