Anaconda安装tensorflow报错问题解决方法

tensorflow 同时被 2 个专栏收录
7 篇文章 0 订阅
13 篇文章 0 订阅

最近脱离了googlecolab想使用本地的anaconda进行机器学习课题的演练,在安装tensorflow时报错 : UnsatisfiableError: The following specifications were found。下面给出解决方法。

发现实际原因是由于anaconda的python环境,当前版本的tensorflow只能适用于python 3.5 3.6 3.7等衍生版本,而anaconda自带的python版本为3.8。

首先打开控制台
使用以下命令可以查看当前的anaconda版本,判断是否正确安装了anaconda。

conda --version

我这里的版本是conda 4.9.1。
在这里插入图片描述

接着列出所有conda中的环境 :

conda info --envs

在这里插入图片描述
查看当前默认环境下的python版本 :

conda activate
python -V

我目前版本是python 3.8
在这里插入图片描述
为了要能成功安装tensorflow,首先我们需要一个低版本python的环境。
执行以下命令,创建一个名字为python37的环境,并跟随提示自动安装python3.7

conda create --name python37 python=3.7

进入新环境,我们重新检查下python版本是不是我们需要的3.7版本。

activate python37
python -V

在配置好我们的python3.7版本之后,我们就可以通过各种方式安装tensorflow了,我这里使用了简明的anaconda navigator的图形界面。
在这里插入图片描述

  • 2
    点赞
  • 0
    评论
  • 4
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

表情包
插入表情
评论将由博主筛选后显示,对所有人可见 | 还能输入1000个字符
©️2021 CSDN 皮肤主题: 点我我会动 设计师:白松林 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值