N - Trailing Zeroes (III) Lightoj 1138

题目链接http://lightoj.com/volume_showproblem.php?problem=1138

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

思路:找5的个数,二分搜答案

Code

#include<bits/stdc++.h>
#define LL long long
const int maxn = 0;
using namespace std;
int pan(int x)
{
    int res=0;
    while(x>=5)
    {
        x/=5;
        res+=x;
    }
    return res;
}
int main()
{
    int T,Case;
    scanf("%d",&T);
    for(Case = 1; Case<=T; Case++)
    {
        int n;
        scanf("%d",&n);
        int l=1,r=1000000000,mid;
        while(l<r-2)
        {
             mid=(l+r)>>1;
            if(pan(mid)>n)
                r=mid+1;
            else if(pan(mid)<n)
                l=mid;
            else
                break;
        }
        mid-=mid%5;
        if(pan(mid)!=n)
        printf("Case %d: impossible\n",Case);
        else
            printf("Case %d: %d\n",Case,mid);
    }

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值