HDU-5326 Work

Work

这里写图片描述

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1694 Accepted Submission(s): 1012

Problem Description

It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people.

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n

Output
For each test case, output the answer as described above.

Sample Input
7 2
1 2
1 3
2 4
2 5
3 6
3 7

Sample Output
2


  1. 题意:每个人只能由一个直属上司管辖,但一个上司可以有多个下属,给出关系数据和管辖人数,问有·多少人满足条件。
  2. 思路:一个关系得出一条指向上司的有向线段,每人都是一个点,用并查数组保存关系,再用一数组保存每个人的管辖人数。枚举每一个人,对于他的上司,管辖人数都加1。将所有人枚举完,所有人管辖人数就得到了。
  3. 失误:根据题意就是要找出一个根结点有多少子结点,但用并查集只能由下向上查找来记录一个子结点有多少父节点,没有想想出合适的方法去转化。
  4. 代码如下:

#include<stdio.h>

const int MAXN=1e6+10;
int fa[MAXN],num[MAXN];

void find2(__int64 x)//对于一个人,能管辖他的人是多少 
{
    __int64 r=x;
    while(r!=fa[r]) 
    {
        r=fa[r];
        ++num[r];//对于他的每个上司 
    }
}

int main()
{
    __int64 n,k,i,cnt,x,y;
    while(~scanf("%I64d %I64d",&n,&k))
    {
        for(i=1;i<=n;++i)
        {
            fa[i]=i;
            num[i]=0;
        }
        for(i=1;i<=n-1;++i)
        {
            scanf("%I64d %I64d",&x,&y);
            fa[y]=x;//无需合并 
        }
        for(i=1;i<=n;++i)//枚举所有人 
        {
            find2(i);  
        }
        cnt=0;
        for(i=1;i<=n;++i)//寻找满足条件的人数 
        {
            if(num[i]==k)  ++cnt;
        }
        printf("%I64d\n",cnt); 
    }
    return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值