数位DP HDU 3555 Bomb

 

Bomb

 

Problem Description

 

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

 

Input

 

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

 

Output

 

For each test case, output an integer indicating the final points of the power.

 

Sample Input

 

 
3 1 50 500
 
Sample Output
 
0 1 15

 

 

 

题意:给出一个数,找到0到这个数之间包含49的数的个数,比如说500的,就是这些数"49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",总共15个

 

这道题算是基础数位DP,我依照这道题做一个基本代码研究

 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
__int64 dp[23][3];
void Init()
{
    int i;
    memset(dp,0,sizeof(dp));
    dp[0][2]=1;
    for(i=1; i<22; i++)
    {
        dp[i][0]=dp[i-1][0]*10+dp[i-1][1];
        dp[i][1]=dp[i-1][2];
        dp[i][2]=dp[i-1][2]*10-dp[i-1][1];
    }
}
int main()
{
    int i,j,Case;
    __int64 num;
    char c[30];
    int a[30];
    Init();
    scanf("%d",&Case);
    while(Case--)
    {
        scanf("%I64d",&num);
        num++;
        int len=0;
        while(num)
        {
            a[++len]=num%10;
            num/=10;
        }

        a[len+1]=0;
        bool flag=0;
        __int64 sum=0;
        for(i=len; i>0; i--)
        {
            sum+=dp[i-1][0]*a[i];
            if(flag)
                sum+=dp[i-1][2]*a[i];
            if(!flag&&a[i]>4)
                sum+=dp[i-1][1];
            if(a[i]==9&&a[i+1]==4)
                flag=1;
        }
        printf("%I64d\n",sum);
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值