POJ 1083 Moving Tables

Moving Tables
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31715 Accepted: 10591

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

题意:如图有很多房间,排列两行,中间有一条单行道,输入两个数ab表示从a房搬桌子到b,每次搬东西花费时间为固定的10分钟,如果10->30 40->20,中间都要经过20-30,所以不能同时进行,一个搬完另一个搬,花费20分钟,详情如上表。最后算最少要多长时间搬完要求的全部。


我选择将1和2看为一点,3和4看为一点。这样就是将房号+1除以2,每次输入起始点,经过的所有点权值+1,最后求叠加次数最多的一点是多少。注意输入两个数的相对大小。

#include<stdio.h>
#include<string.h>
int a[403];
int main()
{
    int t,n,i,j,k,e;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&j,&k);
            if(j>k)
            {
                e=j;
                j=k;
                k=e;
            }
            for(e=(j+1)/2;e<=(k+1)/2;e++)
            {
                a[e]++;
            }
        }
        e=0;
        for(i=0;i<=402;i++)
        {
            if(a[i]>e)
            e=a[i];
        }
        printf("%d\n",e*10);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值