HDU 6441Find Integer

题目链接

                                            Find Integer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2072    Accepted Submission(s): 717
Special Judge

 

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

 

 

Input

one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

 

 

Output

print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

 

 

Sample Input

1

2 3

 

Sample Output

4 5

Source

2018中国大学生程序设计竞赛 - 网络选拔赛

思路:勾股数

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#define in(x) scanf("%d",&x)
#define out(x) printf("%d",x)
using namespace std;
int main()
{
	int t,a,b,c,n,temp;
	in(t);
	while(t--){
		in(n),in(a);
		if(n==2){
			temp=a>>1;
			if(a&1){//如果为奇数 
				b=2*temp*temp+2*temp;
				c=b+1;
			}
			else{//如果为偶数 
				b=temp*temp-1;
				c=b+2;
			}
			printf("%d %d\n",b,c);
		}
		else if(n==1) printf("1 %d\n",a+1);
		else printf("-1 -1\n");
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值