light oj 1248 第六周E题(期望)

E - 期望(经典问题)
Time Limit:1000MS      Memory Limit:32768KB      64bit IO Format:%lld & %llu
 

Description

Given a dice with n sides, you have to find the expected number of times you have to throw that dice to see all its faces at least once. Assume that the dice is fair, that means when you throw the dice, the probability of occurring any face is equal.

For example, for a fair two sided coin, the result is 3. Because when you first throw the coin, you will definitely see a new face. If you throw the coin again, the chance of getting the opposite side is 0.5, and the chance of getting the same side is 0.5. So, the result is

1 + (1 + 0.5 * (1 + 0.5 * ...))

= 2 + 0.5 + 0.52 + 0.53 + ...

= 2 + 1 = 3

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 105).

Output

For each case, print the case number and the expected number of times you have to throw the dice to see all its faces at least once. Errors less than10-6 will be ignored.

Sample Input

5

1

2

3

6

100

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5.5

Case 4: 14.7

Case 5: 518.7377517640

 

题解:n个面的骰子 求每个面至少扔到一次的期望值

比如给你6个面的 他的期望就是6*1+6*(1/2)+6*(1/3)+6*(1/4)+6*(1/5)+6*(1/6)

注意输出格式,小数点后十位。

#include<iostream>
#include<cstdio>
using namespace std;
int n,t,k=1;
double dp[100005];
int main()
{
    cin>>t;
    while(t--)
    {
       cin>>n;
       dp[n]=0;
       for(int i=n-1;i>=0;i--)
        dp[i]=dp[i+1]+(double)n/(i+1);
        printf("Case %d: %.10lf\n",k++,dp[0]);
    }
    return 0;
}

 

 

 

转载于:https://www.cnblogs.com/hfc-xx/p/4740781.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值