*斐波拉契数列(取余)

Problem K
Time Limit: 1000 MS Memory Limit: 32 MB 64bit IO Format: %I64d
Submitted: 225 Accepted: 51
[Submit][Status][Web Board]
Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

由于mod7,f(n)的取值只可能在0-6中取值,而A和B不变,所以必然会循环,且循环节不会超过7*7=49;

#include <stdio.h>
int main()
{
    long long  a,b,n,i,s,q,p;
    while(scanf("%I64d%I64d%I64d",&a,&b,&n)!=EOF)
    {
        if(a==0&&b==0&&n==0)
            break;
        p=1;
        q=1;
        if(n==1||n==2)
            printf("1\n");
        else
        {
            n=n%49;
            for(i=3; i<=n; i++)
            {
                s=(a*q+b*p)%7;
                p=q;
                q=s;
            }
            printf("%I64d\n",s);
        }

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值