hdu4634:bfs+状压

Description
“Swipe Bo” is a puzzle game that requires foresight and skill.
The main character of this game is a square blue tofu called Bo. We can swipe up / down / left / right to move Bo up / down / left / right. Bo always moves in a straight line and nothing can stop it except a wall. You need to help Bo find the way out.
The picture A shows that we needs three steps to swipe Bo to the exit (swipe up, swipe left, swipe down). In a similar way, we need only two steps to make Bo disappear from the world (swipe left, swipe up)!
这里写图片描述

Look at the picture B. The exit is locked, so we have to swipe Bo to get all the keys to unlock the exit. When Bo get all the keys, the exit will unlock automatically .The exit is considered inexistent if locked. And you may notice that there are some turning signs, Bo will make a turn as soon as it meets a

这里写图片描述

turning signs. For example, if we swipe Bo up, it will go along the purple line.
Now, your task is to write a program to calculate the minimum number of moves needed for us to swipe Bo to the exit.

Input
The input contains multiple cases, no more than 40.
The first line of each test case contains two integers N and M (1≤N, M≤200), which denote the sizes of the map. The next N lines give the map’s layout, with each line containing M characters. A character is one of the following: ‘#’: represents the wall; ‘S’ represents the start point of the Bo; ‘E’ represents the exit; ‘.’ represents an empty block; ‘K’ represents the key, and there are no more than 7 keys in the map; ‘L’,’U’,’D’,’R’ represents the turning sign with the direction of left, up, down, right.
Output
For each test case of the input you have to calculate the minimal amount of moves which are necessary to make Bo move from the starting point to the exit. If Bo cannot reach the exit, output -1. The answer must be written on a single line.

Sample Input
5 6

#

….

.E…#
..S.##
.#####
5 6

#

….

…..#
SEK.##
.#####
5 6

#

….

….K#
SEK.##
.#####
5 6

#

….

D…E#
S…L#
.#####

Sample Output
3
2
7
-1

思路:
再说一遍,当题目给的某一数据很小的时候就要想到状压!
本题最多只有七个钥匙!!!!!!!!!!
由于走同一个地方的时候可能会手中拿的钥匙不一样,所以要将钥匙加入到标记数组中,用状压然后用位运算合并结果

#include <cstdio>
#include <queue>
#include <cstring>
#include <iostream>
#include <algorithm>
#pragma comment (linker,"/STACK:10240000,10240000")
using namespace std;
struct node
{
    int x,y,step,cll;
    node(int a=0,int b=0,int c=0,int d=0):x(a),y(b),step(c),cll(d) {}
};
char mp[200][200];
bool vis[200][200][1<<7][4];//注意!布尔类型!!!(爆内存无数遍)
int n,m,keys;
int dx[]= {0,0,1,-1},dy[]= {1,-1,0,0};
int sx,sy,ex,ey;
int bfs()
{
    queue<node> q;
    memset(vis,0,sizeof vis);
    q.push(node(sx,sy,0,0));
    while(!q.empty())
    {
        node pre=q.front();
        q.pop();
        for(int i=0; i<4; i++)
        {
            int xx=pre.x,yy=pre.y,ky=pre.cll,ss=pre.step;
            int mx=dx[i],my=dy[i],mo=i;
            while(1)//好好体会一下这个while1
            {
                if(mp[xx][yy]=='L') mx=0,my=-1,mo=1;
                else if(mp[xx][yy]=='R')mx=0,my=1,mo=0;
                else if(mp[xx][yy]=='U')mx=-1,my=0,mo=2//再想一遍!!!!!向上是加还是减!!!!
                else if(mp[xx][yy]=='D') mx=1,my=0,mo=3;
                if(vis[xx][yy][ky][mo])
                    break;
                vis[xx][yy][ky][mo]=1;
                if(mp[xx][yy]>='0'&&mp[xx][yy]<'9')
                    ky|=1<<(mp[xx][yy]-'0');
                if(xx==ex&&yy==ey&&ky==(1<<keys)-1)
                    return ss+1;
                if(xx+mx>=0&&xx+mx<n&&yy+my>=0&&yy+my<m)
                {
                    if(mp[xx+mx][yy+my]=='#')
                    {
                        q.push(node(xx,yy,ss+1,ky));
                        break;
                    }
                    else xx+=mx,yy+=my;
                }
                else break;
            }
        }
    }
    return -1;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        keys=0;
        for(int i=0; i<n; i++)
        {
            scanf("%s",mp[i]);
            for(int j=0; j<m; j++)
            {
                if(mp[i][j]=='E')
                    ex=i,ey=j;
                if(mp[i][j]=='S')
                    sx=i,sy=j;
                if(mp[i][j]=='K')
                {
                   mp[i][j]=(keys+'0');
                   keys++;
                }
            }
        }
        printf("%d\n",bfs());
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值