POJ 1274 The Perfect Stall 二分匹配||最大流(简单题)

点击打开链接

 

The Perfect Stall
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16555 Accepted: 7575

Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 

Sample Output

4

Source

 
题意是说有n头cows和m个stalls。每头cows都有自己向往的stalls,但是每个stall只能容纳一头cow,每头cow也只能进一个stall。现在给你每头cow所向往的stall,让你求最多有多少头cows可以到自己向往的stall。
二分匹配和最大流都可以解决此题,都是比较简单的。
二分匹配:
#include<stdio.h>
#include<string.h>
#define M 207
using namespace std;
int g[M][M],link[M];
bool vis[M];
int n,m;

bool find(int i)
{
    for(int j=1;j<=n;j++)
        if(g[i][j]&&!vis[j])
        {
            vis[j]=true;
            if(link[j]==0||find(link[j]))
            {
                link[j]=i;
                return true;
            }
        }
        return false;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(link,0,sizeof(link));
        memset(g,0,sizeof(g));
        int num,a,count=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num);
            while(num--)
            {
                scanf("%d",&a);
                g[i][a]=1;
            }
        }
        for(int i=1;i<=n;i++)
        {
            memset(vis,false,sizeof(vis));
            if(find(i))
                count++;
        }
        printf("%d\n",count);
    }
    return 0;
}

 
最大流:
建立一个超级源点和一个超级汇点,将cows与超级源点相连,容量为1.stalls与汇点连接,容量为1,然后cows与stalls连接,容量为1.求出最大流即可。
 
 
#include<stdio.h>
#include<string.h>
#include<queue>
#define M 507
#define inf 0x3f3f3f
using namespace std;
int g[M][M],pre[M],c[M],flow[M][M];
int n,m;

int EK(int s,int t)
{
    memset(flow,0,sizeof(flow));
    int sum=0;
    queue<int>q;
    for(;;)
    {
        memset(c,0,sizeof(c));
        c[s]=inf;
        q.push(s);
        while(!q.empty())
        {
            int u=q.front();
            q.pop();
            for(int i=0;i<=t;i++)
                if(!c[i]&&g[u][i]>flow[u][i])
                {
                    pre[i]=u;
                    q.push(i);
                    c[i]=c[u]<g[u][i]-flow[u][i]?c[u]:g[u][i]-flow[u][i];
                }
        }
        if(!c[t])break;
        for(int i=t;i!=s;i=pre[i])
        {
            flow[pre[i]][i]+=c[t];
            flow[i][pre[i]]-=c[t];
        }
        sum+=c[t];
    }
    return sum;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(g,0,sizeof(g));
        memset(pre,0,sizeof(pre));
        int s=0;
        int t=n+m+1;
        int num,a;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num);
            g[s][i]=1;
            while(num--)
            {
                scanf("%d",&a);
                g[i][a+n]=1;
            }
            for(int i=1;i<=m;i++)
                g[i+n][t]=1;
        }
        int max=EK(s,t);
        printf("%d\n",max);
    }
    return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值