POJ 1753 Flip Game 翻转(枚举+dfs)


Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27023 Accepted: 11706

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source



题意是说给你一个黑白的4*4的棋盘,让你翻转一些棋子,使其最终棋盘所有棋子为一个颜色,问最少翻转多少棋子,并且翻转一个棋子的时候,它的上下左右也要翻转。
没枚棋子可以翻转0或者1次,因为翻转2,4,....等偶数次跟翻转0次效果一次,同样翻转奇数次跟翻转1次效果也是一样。因为最多执行16次,所以可以枚举所有情况,找出最小的就可以了。
#include<stdio.h>
#include<iostream>
using namespace std;
int g[4][4];
int n,m,maxx=100;
void turn(int x,int y)
{
    if(x>=0&&x<4&&y>=0&&y<4)
        g[x][y]=!g[x][y];
}
void flip(int id)//翻转
{
    int i=id/4;
    int j=id%4;
    turn(i,j);
    turn(i+1,j);
    turn(i-1,j);
    turn(i,j-1);
    turn(i,j+1);
}
bool solve()//判断是否全部为用同一颜色
{
    for(int i=0;i<4;i++)
        for(int j=0;j<4;j++)
            if(g[i][j]!=g[0][0])
                return false;
    return true;
}
void dfs(int id,int num)//id代表当前方格,num代表翻转的次数
{
    if(solve())
    {
        if(maxx>num)
            maxx=num;
        return ;
    }
    if(id>=16)return ;
    dfs(id+1,num);
    flip(id);
    dfs(id+1,num+1);
    flip(id);
}
int main()
{
    char c;
    for(int i=0;i<4;i++)
        for(int j=0;j<4;j++)
        {
            cin>>c;
            //c=getchar();
            if(c=='w')g[i][j]=0;
            else g[i][j]=1;
        }
    dfs(0,0);
    if(maxx==100)printf("Impossible\n");//最多翻转4*4*2=32次
    else printf("%d\n",maxx);
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值