POJ - 2385 Apple Catching

Apple Catching
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13034 Accepted: 6331

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

题意:有两棵树1,2。起始位置是在树1下。给出序列表示第i时刻哪棵树掉苹果,给出转换次数w,问在w范围内最多可以拿到的苹果。

一眼看出dp,但是没一下子想出该怎么d……

看了大神的思路才想到用时刻和转移次数来d

按时间来思考,一给定时刻i,转移次数已知为j, 则它只能由两个状态转移而来。

即上一时刻同一棵树或上一时刻不同的树

则这一时刻在转移次数为j的情况下最多能接到的苹果为那两个状态的最大值再加上当前能接受到的苹果。

细节地方看代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int dp[1010][35];
	int a[10010];
	int i,j,n,m;
	scanf("%d%d",&n,&m);
	for(i=1;i<=n;i++)
		scanf("%d",&a[i]);
	memset(dp,0,sizeof(dp));
	if(a[1]==1)
		dp[1][0]=1;//如果一开始是树1掉
	else
		dp[1][1]=1;
	for(i=2;i<=n;i++)
	{
		for(j=0;j<=m;j++)
		{
			if(j==0)
			{
				dp[i][j]=dp[i-1][j]+(a[i]%2);//当j==0时看这一时刻哪棵树掉
				continue;
			}
			dp[i][j]=dp[i-1][j]>dp[i-1][j-1]?dp[i-1][j]:dp[i-1][j-1];//当j!=0时,看上一时刻不同的树
			if(j%2+1==a[i])//j为奇数在树1下为偶数在树2下
				dp[i][j]++;
		}
	}
	int ans=dp[n][0];
	for(i=0;i<=m;i++)
	{
		ans=max(ans,dp[n][i]);
	}
	printf("%d\n",dp[n][m]);
	
 } 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值