PAT甲级 1001 A+B Format (20 分)

该博客主要讨论如何处理字符串以符合特定的格式要求,例如将数字的和以每三位一组的方式用逗号分隔。输入是两个大整数,输出是它们的和,按照标准格式展示。示例中,输入为-10000009,输出为-999,991。博客内容涉及C++编程,字符串操作和格式化输出技巧。
摘要由CSDN通过智能技术生成

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10​6≤a,b≤10​6. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9

Sample Output:
-999,991

核心思想是如何去处理字符串,我开始写的时候用int直接去处理,其实就偏离了题目的本意。本题的核心就是通过字符串处理,代码当时有两个点过不去,主要是因为没有判断到如果是最后一位是3的整除情况

#include <iostream>

using namespace std;

int main() {
    int a, b;
    cin >> a >> b;
    string c = to_string(a + b);
    string res;
    for (int i = c.size() - 1, j = 0; i >= 0; i--) {
        res = c[i] + res;
        j++;
        if (j % 3 == 0 and c[i - 1] != '-' and i)
            res =  ',' + res;
    }
    cout<<res<<endl;
    return 0;
}

有些人问我 为啥没有string 头文件 其实iostream里面已经包含了

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

XdpCs

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值