为ActiveMQ指定jdk

标签: activemq
7人阅读 评论(0) 收藏 举报
分类:

http://zz563143188.iteye.com/blog/1885132 


我是用ActiveMQ安装目录下的bin目录下的activemq.bat文件启动ActiveMQ的,所有我需要修改该文件。

       找到如下位置:
      
引用
if "%JAVA_HOME%" == "" goto noJavaHome
if not exist "%JAVA_HOME%\bin\java.exe" goto noJavaHome
if "%_JAVACMD%" == "" set _JAVACMD=%JAVA_HOME%\bin\java.exe
goto runAnt


       这个位置就是判断JAVA_HOME变量的位置。所有我在这个之前添加如下语句:
      

引用
set JAVA_HOME=C:\Program Files\Java\jdk1.5.0_22
查看评论

项目实战:ActiveMQ开发大型分布式系统

消息中间件是搭建大型企业级项目必不可少的成员,只有掌握了消息中间件的使用和应用场景,才能开发真正的大型分布式系统。 ActiveMQ支持JMS,是apache的顶级项目,在全球开源消息中间件中影响力最大!
  • 2017年08月14日 15:46

为activemq指定运行的jdk版本

在一个linux上配置了环境变量的JAVA_HOME是jdk1.6的, 而最新的activemq-5.14.3  运行/bin/activemq 会报错不支持这个版本的jdk,..............
  • lsm135
  • lsm135
  • 2017-01-05 13:13:10
  • 6122

activemq指定java路径问题

今天下载了个window版本的apache-activemq-5.14.5-bin.zip解压运行bin\win64的bat文件是报了个版本的错误,因为自己机器的java_home是指向1.6的 所...
  • z3111001358
  • z3111001358
  • 2017-05-19 02:14:02
  • 928

activemq java版本要求

activemq: redis01:/root# cp apache-activemq-5.13.2-bin.tar.gz /usr/local/ 安装目录: redis01:/usr/local...
  • zhaoyangjian724
  • zhaoyangjian724
  • 2016-05-30 11:53:00
  • 3263

ActiveMQ5.11.1和JDK版本的匹配关系

环境:MyEclipse2015+ActiveMQ5.11.1 使用不同版本的JDK,执行Java application时会出现不同的表现。 1、JDK版本为jdk1.5/J2S...
  • zxygww
  • zxygww
  • 2015-05-22 18:50:44
  • 3987

Apache ActiveMQ 各个版本所依赖的JDK版本

JAVA版本列表 发布版本号 内部版本号(十进制) 内部版本号(十六进制) 1.5 31 49 1.6 32 50 1.7 33 ...
  • yanfeipei
  • yanfeipei
  • 2017-07-17 20:05:42
  • 5434

linux安装Apache ActiveMQ 5.15.3

1.下载Apache ActiveMQ 5.15.3 下载地址 :http://activemq.apache.org/download.html2. 安装把下载好的activemq-5.15.3-b...
  • u010938610
  • u010938610
  • 2018-04-14 14:03:32
  • 36

JDK多版本下如何设置jdk 1.8为默认jdk

1.将jdk 1.8下载解压 2.增加新的java alternatives  --install /usr/bin/java  java /apps/svr/jdk1.8.0_91/bin/ja...
  • zengxuewen2045
  • zengxuewen2045
  • 2016-06-27 22:48:32
  • 732

ApacheActiveMQ安装必要条件

ApacheActiveMQ安装必要条件
  • myNameIssls
  • myNameIssls
  • 2016-05-03 10:37:12
  • 558

ActiveMQ5.11.1必须在JDK1.7以上版本才能使用。

ActiveMQ5.11.1必须在JDK1.7以上版本才能使用。
  • dfrg345
  • dfrg345
  • 2017-08-11 15:40:53
  • 534
    个人资料
    持之以恒
    等级:
    访问量: 32万+
    积分: 5610
    排名: 5883
    最新评论