HDU 1018 Big Number

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21327    Accepted Submission(s): 9598


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19
 

Source
 

Recommend
JGShining
这题真心纠结....一开始做的时候题目没看清( factorial of the number为数的阶乘)..后来找到N!所有的位数=Log10(1*2*3*...*N)=log1+log2+log3+..+logN即可.....但是没有注意log10()函数的形参要指定为浮点数.....纠结—虽然用整数也能得到正确结果..(让我抓狂的是..我按这个来了....结果却一直不对...但是现在还没找到....)
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
  int t,n;
  double sum;
  cin>>t;
  while(t--)
  {
      cin>>n;
      sum=0;
      for(int i=1;i<=n;i++)
      sum+=log10(i+0.0);
      cout<<(int)sum+1<<endl;
  }
  return 0;
}

方法二: 由斯特林[striling]公式可得:lnN!=NlnN-N+0.5ln(2N*pi) 【不懂】

而N的阶乘的位数等于:log10(N!)取整后加1

log10(N!)=lnN!/ln(10) 所以len=lnN!/ln(10)+1

#include <iostream>
#include <cmath>
#define pi acos(-1.0)
using namespace std;
int main()
{
    int t,n;
    cin >> t;
    while(t-- && cin >> n)
    {
              double sum = (n*log(n)-n+0.5*log(2*n*pi))/log(10);
              cout << (int)sum+1 << endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值