HDOJ 2161 Primes

题目链接:点击打开链接


本题采用素数打表法会快很多。本题还应该注意,题目要求2不是素数!


素数打表法,就是先开一个最大要求的布尔型数组(整型数组也行) 然后判断下标是否为素数,下标如果是素数则设立为true;否则为false


Primes

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12429    Accepted Submission(s): 5149


Problem Description
Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes.
 

Input
Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.
 

Output
The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by "yes" or "no".
 

Sample Input
  
  
1 2 3 4 5 17 0
 

Sample Output
  
  
1: no 2: no 3: yes 4: no 5: yes 6: yes

具体代码实现:

package cn.hncu.acm;

import java.util.Scanner;

public class P2161 {
	public static void main(String[] args) {
		boolean a[]=new boolean[16001];
		/*
		 * 下面是一个快速判断素数的方法
		 * 也可以使用一般的判断方法
		 */
		for(int i=1;i<16001;i++){
			a[i]=true;
		}
		a[1]=a[2]=false;
		for(int i=2;i<16001;i++){
			for(int j=i+i;j<16001;j+=i){	
				//每次加i(因为一个数的倍数 肯定不是素数)
				a[j]=false;
			}
		}
		Scanner sc=new Scanner(System.in);
		int count=1;
		while(sc.hasNext()){
			int n=sc.nextInt();
			if(n<=0){
				break;
			}
			if(a[n]){
				System.out.println(count+": yes");
			}else{
				System.out.println(count+": no");
			}
			count++;
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值