Python默认编码及requests模块问题

今天在用一个POC测试漏洞的时候,遇到了两个问题,由于对Python脚本不熟悉,所以百度了一下解决方法。很快问题就解决了,来个总结:

问题一:

在运行Python脚本时候直接提示:“SyntaxError: Non-ASCII character '\xe5……'  ”

查了一下是Python默认编码错误。这个错误是由于使用了中文输出或用中文对脚本进行注释,并且将文件存成了UTF-8。Python的默认编码文件用的是ASCII码。

解决方法:

在文件开头加入:

# -*- coding: UTF-8 -*-    或者  #coding=utf-8

注:此语句一定要添加在源代码的第一行

问题二:

当直接运行POC脚本时候,出现了错误,错误提示如下图所示:


这个是Python中requests模块导入问题是由于没有安装requests模块造成的。

在cmd里将目录切换到pip所在路径(即切换到Srcipts目录下),安装requests模块,命令:pip install requests。如下图所示:


成功安装后,提示我的pip版本是9.0.1,现在有10.0.1可以用,我又把pip升级到10.0.1版本。如下如所示:


现在终于可以成功运行POC脚本了。


阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页