POJ3278(BFS广度优先搜索)之Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4


题意:

给你两个整数n和k
通过 n+1或n-1 或n*2 这3种操作,使得n==k
输出最少的操作次数


AC代码如下:

#include "iostream"
#include "cstdio"
#include "cstring"
#include "queue"
using namespace std;


const int maxn=100000*2+100;


bool visit[maxn];
int last[maxn];


int main(int argc, char* argv[])
{
	int n,k,v;
	cin>>n>>k;
	
	if (n==k)
	{
		cout<<0<<endl;
		return 0;
	}
	memset(visit,false,sizeof(visit));
	queue<int> q;
	q.push(n);
	while(!q.empty())
	{
		int u=q.front(); q.pop();
		v=u;
		if (v==k)
		{
			vector<int> nodes;
			for (;;)
			{
				nodes.push_back(v);
				if (last[v]==n)
				{
					break;
				}
				v=last[v];
			}
			cout<<nodes.size()<<endl; return 0;
		}
		for (int i=0;i<3;i++)
		{
			if (i==0)
			{
				v=u-1;
				if (u-1>=0 && !visit[v])
				{
					q.push(v);
					visit[v]=true;
					last[v]=u;
				}
			}
			else if(i==1)
			{
				v=u+1;
				if (u<=k && !visit[v])
				{
					q.push(v);
					visit[v]=true;
					last[v]=u;
				}
			}
			else if(i==2)
			{
				v=u*2;
				if (u<=k && !visit[v])
				{
					q.push(v);
					visit[v]=true;
					last[v]=u;
				}
			}
			if (v==k)
			{
				vector<int> nodes;
				for (;;)
				{
					nodes.push_back(v);
					if (last[v]==n)
					{
						break;
					}
					v=last[v];
				}
				cout<<nodes.size()<<endl;return 0;
			}
		}
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值