Circle Barn

Being a fan of contemporary architecture, Farmer John has built a new barn in the shape of a perfect circle. Inside, the barn consists of a ring of n rooms, numbered clockwise from 1…n around the perimeter of the barn (3≤n≤1,000). Each room has doors to its two neighboring rooms, and also a door opening to the exterior of the barn.
Farmer John wants exactly ri cows to end up in each room i (1≤ri≤100). To herd the cows into the barn in an orderly fashion, he plans to unlock the exterior door of a single room, allowing the cows to enter through that door. Each cow then walks clockwise through the rooms until she reaches a suitable destination. Farmer John wants to unlock the exterior door that will cause his cows to collectively walk a minimum total amount of distance. Please determine the minimum total distance his cows will need to walk, if he chooses the best such door to unlock. The distance walked by a single cow is the number of interior doors through which she passes.
输入
The first line of input contains n. Each of the remaining n lines contain r1…rn.
输出
Please write out the minimum total amount of distance the cows collectively need to travel.

输入样例
5
4
7
8
6
4
输出样例
48

#include <iostream>
#include <bits/stdc++.h>

using namespace std;
int sum[1005];
int main()
{
    int n;
    int a[1005],i,j,k,min;
    scanf("%d",&n);
    for (i=0; i<n; i++)
    {
        scanf("%d",&a[i]);
    }
    for (i=0; i<n; i++)
    {
        k=0;
        j=i;
        while(1)
        {
            sum[i]=a[j]*k+sum[i];
            k++;
            if (j==n-1)
            {
                if (i==0)
                    break;
                j=0;
                continue;
            }
            if (j==i-1)
                break;
            j++;

        }
    }
    min=sum[0];
    for (i=0; i<n; i++)
    {
        if (sum[i]<min)
            min=sum[i];

    }
    printf("%d",min);
    return 0;
}


暴力出奇迹

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值