Work(树DP模板题)

171 篇文章 0 订阅
102 篇文章 0 订阅


Link:http://acm.hdu.edu.cn/showproblem.php?pid=5326

Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 490    Accepted Submission(s): 343


Problem Description


It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people. 
 

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 

Output
For each test case, output the answer as described above.
 

Sample Input
  
  
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output
  
  
2
 

Source
 

AC code:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<map>
#include<cmath>
#define LL long long
#define MAXN 1000010
using namespace std;
int father[MAXN],dp[MAXN];
bool vis[MAXN];
int n,k;
void tree_dp(int root)
{
	vis[root]=true;
	for(int i=1;i<=n;i++)
	{
		if(!vis[i]&&father[i]==root)
		{
			tree_dp(i);
			dp[root]+=dp[i];
		}
	}
}
int main()
{
	int u,v,i,j,ans;
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		int m=n-1;
		memset(father,0,sizeof(father));
		memset(vis,false,sizeof(vis));
		for(i=1;i<=n;i++)
		{
			dp[i]=1;
		}
		while(m--)
		{
			scanf("%d%d",&u,&v);
			father[v]=u;
		}
		int root=u;
		while(father[root])
			root=father[root];
		tree_dp(root);
		ans=0;
		for(i=1;i<=n;i++)
		{
			if(dp[i]-1==k)
			{
				ans++;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
 } 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值