hdu 1010 Tempter of the Bone(DFS)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1010

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

 

 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

 

 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

 

 

Sample Input

 

4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0

 

 

Sample Output

 

NO YES

 

 

一道DFS,感觉数据有问题,数据水了。而且DFS没有剪枝也过不去的

#pragma GCC optimize(2)
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<set>
#include<vector>
#include<string>
#include<queue>
#include<math.h>
using namespace std;
const int maxn = 20;
const int inf = 0x3f3f3f3f;
typedef long long ll;
int d[4][2] = { 1,0,-1,0,0,1,0,-1 };
char mp[maxn][maxn];
bool vis[maxn][maxn];
int t, n, m, op;
int t_x, t_y;
int e_x, e_y;
int flag = 0;
void dfs(int x, int y)
{
	if (flag)
	{
		return;
	}
	for (int i = 0; i < 4; i++)
	{
		int o_x = x + d[i][0];
		int o_y = y + d[i][1];
		if (o_x >= n || o_x < 0 || o_y < 0 || o_y >= m || vis[o_x][o_y] == 1 ||mp[o_x][o_y] == 'X')
		{
			continue;
		}
		if (mp[o_x][o_y] == '.')
		{
			vis[o_x][o_y] = 1;
			op--;
			dfs(o_x, o_y);
			vis[o_x][o_y] = 0;
			op++;
		}
		if (mp[o_x][o_y] == 'D'&&op==1)
		{
			flag = 1;
			return;
		}
	}
}
int main()
{
	//freopen("C://input.txt", "r", stdin);
	while (scanf("%d%d%d", &n, &m, &op) != EOF)
	{
		flag = 0;
		if (n == 0 && m == 0 && op == 0)
		{
			break;
		}
		memset(vis, 0, sizeof(vis));
		for (int i = 0; i < n; i++)
		{
			for (int j = 0; j < m; j++)
			{
				cin >> mp[i][j];
				if (mp[i][j] == 'S')
				{
					t_x = i;
					t_y = j;
				}
				if (mp[i][j] == 'D')
				{
					e_x = i;
					e_y = j;
				}
			}
		}
		dfs(t_x, t_y);
		if (flag)
		{
			printf("YES\n");
		}
		else
			printf("NO\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值