PAT (Advanced Level) Practice 1009 Product of Polynomials(25分)【模拟】

This time, you are supposed to find A × B A×B A×B where A A A and B B B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N ​ 1 ​ ​ a ​ N ​ 1 ​ ​ N ​ 2 ​ ​ a ​ N ​ 2 ​ ​ . . . N ​ K a N K K N​_1​​ a_{​N​_1}​​ N​_2​​ a​_{N​_2}​​ ... N​_K a_{N_K} KN1aN1N2aN2...NKaNK
where K K K is the number of nonzero terms in the polynomial, N ​ i N_​i Ni and a N i ( i = 1 , 2 , ⋯ , K ) a_{N_i} (i=1,2,⋯,K) aNi(i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1 ≤ K ≤ 10 , 0 ≤ N K < ⋯ < N 2 < N 1 ≤ 1000 1≤K≤10, 0≤N_K<⋯<N_2<N_1≤1000 1K10,0NK<<N2<N11000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

题意

求多项式A*B

思路

先读入第一个多项式,在读入第二个时,计算当前项与第一个多项式的每一项相乘的结果,累加起来就是最后的答案。

代码

#include <cstdio>
#include <cmath>

using namespace std;

const int SIZE = 2005;
const double EPS = 1e-8;
double arr[SIZE], res[SIZE];

int main() {
    for (int i = 0; i < 2; ++i) {
        int n;
        scanf("%d", &n);
        for (int j = 0; j < n; ++j) {
            int exp;
            double cof;
            scanf("%d %lf", &exp, &cof);

            if (i == 0) arr[exp] = cof;
            else
                for (int k = 0; k <= 1000; ++k)
                    res[k + exp] += cof * arr[k];
        }
    }

    int cnt = 0;
    for (int i = 0; i < SIZE; ++i)
        if (fabs(res[i]) > EPS) ++cnt;
    printf("%d", cnt);

    if (cnt)
        for (int i = SIZE - 1; i >= 0; --i)
            if (fabs(res[i]) > EPS) printf(" %d %.1f", i, res[i]);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值