<?xml version="1.0" encoding="utf-8" ?><rss version="2.0"><channel><title><![CDATA[F2001523的博客]]></title><description><![CDATA[]]></description><link>https://blog.csdn.net/F2001523</link><language>zh-cn</language><generator>https://blog.csdn.net/</generator><copyright><![CDATA[Copyright &copy; F2001523]]></copyright><item><title><![CDATA[Docker——Compose搭建consul集群]]></title><link>https://blog.csdn.net/F2001523/article/details/114853530</link><guid>https://blog.csdn.net/F2001523/article/details/114853530</guid><author>F2001523</author><pubDate>Mon, 15 Mar 2021 22:06:02 +0800</pubDate><description><![CDATA[文章目录前言一、Docker Compose简介1.什么是Docker Compose?2.YAML语言3.使用Docker Compose的三个步骤二、Docker Compose配置字段与命令1.Docker Compose配置常用字段2.Docker Compose常用命令3.Cocker Compose命令参数三、Docker编排Nginx四、Consul容器自动更新与发现1.Consul简介2.Consul的特点3.容器服务更新与发现拓扑图4.consul集群部署4.1 安装 consul-tem]]></description><category></category></item><item><title><![CDATA[Mysql报错：Error_code: 1032；handler error HA_ERR_KEY_NOT_FOUND]]></title><link>https://blog.csdn.net/F2001523/article/details/114805289</link><guid>https://blog.csdn.net/F2001523/article/details/114805289</guid><author>F2001523</author><pubDate>Sun, 14 Mar 2021 21:46:38 +0800</pubDate><description><![CDATA[文章目录一、问题二、解决方法1. 方法一2.方法二
一、问题
mysql-5.6.20主从同步错误之Error_code: 1032; handler error HA_ERR_KEY_NOT_FOUND或（主从复制，当主从同步状态异常时，通过对比检查二进制文件和中继日志文件，发现master 和slave 节点之间同步的位置点发生了偏移，请问这可能时什么情况引起的，如何解决）
二、解决方法
1. 方法一
1.Error_code: 1032; handler error HA_ERR_KEY_NOT_FO]]></description><category></category></item><item><title><![CDATA[Docker私有仓库、数据卷和数据卷容器、容器互联]]></title><link>https://blog.csdn.net/F2001523/article/details/114804828</link><guid>https://blog.csdn.net/F2001523/article/details/114804828</guid><author>F2001523</author><pubDate>Sun, 14 Mar 2021 21:36:20 +0800</pubDate><description><![CDATA[文章目录一、Docker私有仓库1.下载仓库镜像2.启动registry容器二、Docker数据卷（宿主机与容器之间实现数据共享）1.数据卷（宿主机和容器的挂载）三、数据卷容器（容器与容器之间实现数据共享）1.数据卷容器：容器和容器挂载四、容器互联
一、Docker私有仓库
1.下载仓库镜像
docker pull registry

docker images


vi /etc/docker/daemon.json #指定私有仓库位置

{
  "insecure-registries": ["20.0]]></description><category></category></item><item><title><![CDATA[Dockerfile创建镜像的三种方式（Dockerfile、基于已有的镜像容器、基于本地模板）]]></title><link>https://blog.csdn.net/F2001523/article/details/114803742</link><guid>https://blog.csdn.net/F2001523/article/details/114803742</guid><author>F2001523</author><pubDate>Sun, 14 Mar 2021 21:18:47 +0800</pubDate><description><![CDATA[文章目录一、镜像分层模型二、Dockerfile简介1.Dockerfile操作指令2.构建镜像三种方式2.1 Dockerfile2.1.1 使用Dockerfile构建Apache2.1.2 使用Dockerfile构建Nginx2.1.3 使用Dockerfile构建Tomcat2.2 基于已有的镜像容器进行创建镜像2.3 基于本地模板进行构建
一、镜像分层模型

容器（可读，可写层）
服务本身镜像层（只读层，模板）
依赖环境镜像层（只读层，模板）
基础镜像镜像层（为以上的系统服务提供支持）
底层内核]]></description><category></category></item><item><title><![CDATA[Docker网络模式（host，container，none，bridge）和资源控制管理]]></title><link>https://blog.csdn.net/F2001523/article/details/114803047</link><guid>https://blog.csdn.net/F2001523/article/details/114803047</guid><author>F2001523</author><pubDate>Sun, 14 Mar 2021 21:03:18 +0800</pubDate><description><![CDATA[文章目录一、Docker网络类型二、Docker自定义网络1. 查看网络列表2. 根据镜像创建容器并指定ip地址3. 根据镜像创建容器不指定ip地址4. 查看创建容器ip地址三、自定义网络网桥固定IP1. 自定义创建网桥2. 定义分配地址3. 进行网关通信测试，通过ens33物理网卡进行通信四、Docker资源控制（CPU、内存、Io资源制）1. 引导2. CPU使用率控制3. 动态查看cpu使用率4. 20%的限定4.1 方式一、在创建容器运行进行资源限制4.2 方式二、对已经存在且在运行时状态的容器进行]]></description><category></category></item><item><title><![CDATA[在安装Docker-CE的时候遇到报错：Error: Package: 3:docker-ce-20.10.5-3.el7.x86_64 (docker-ce-stable) Requires: co]]></title><link>https://blog.csdn.net/F2001523/article/details/114488938</link><guid>https://blog.csdn.net/F2001523/article/details/114488938</guid><author>F2001523</author><pubDate>Sun, 07 Mar 2021 16:47:45 +0800</pubDate><description><![CDATA[文章目录一、报错信息二、解决思路三、解决办法1.最小化安装解决办法2.不是最小化安装四、测试
一、报错信息
在安装Docker-CE的时候遇到报错：
Error: Package: 3:docker-ce-20.10.5-3.el7.x86_64 (docker-ce-stable)
Requires: container-selinux &gt;= 2:2.74

二、解决思路
Error: Package: 3:docker-ce-20.10.5-3.el7.x86_64 (docker-ce-stab]]></description><category></category></item><item><title><![CDATA[什么是Docker?Docker安装及镜像、容器的基本命令实验+理论!!!]]></title><link>https://blog.csdn.net/F2001523/article/details/114487040</link><guid>https://blog.csdn.net/F2001523/article/details/114487040</guid><author>F2001523</author><pubDate>Sun, 07 Mar 2021 16:42:48 +0800</pubDate><description><![CDATA[文章目录一、安装流程1.安装依赖包2.设置阿里云镜像源3.安装Docker-CE（社区版docker）（在yum安装的时候，除了必要的镜像源之外，还要有以前的repo包，防止报错）4. 关闭防火墙、核心防护5.启动服务与自启动6.查看docker版本7.查看docer信息8.镜像加速9.重新加载服务配置文件10.重启docker11.查看镜像信息（在公有仓库进行搜索）12.下载镜像（是从官网仓库进行下载的）13.查看镜像
一、安装流程
1.安装依赖包
yum install -y yum-utils dev]]></description><category></category></item><item><title><![CDATA[OpenStack-T版——cinder块存储服务]]></title><link>https://blog.csdn.net/F2001523/article/details/114444505</link><guid>https://blog.csdn.net/F2001523/article/details/114444505</guid><author>F2001523</author><pubDate>Sat, 06 Mar 2021 16:02:37 +0800</pubDate><description><![CDATA[文章目录一、cinder简介二、OpenStack-cinder 组件部署1. 创建数据库实例和角色2. 创建用户、修改配置文件2.1创建cinder用户,密码设置为CINDER_PASS2.2 把cinder用户添加到service服务中，并授予admin权限2.3 .cinder有v2和v3两个并存版本的API，所以需要创建两个版本的service实例2.4. 给v2和v3版本的api创建endpoint3. 安装及配置cinder服务4. 在计算节点c2配置Cinder（存储节点）5. 查看卷列表(c]]></description><category></category></item><item><title><![CDATA[OpenStack-T版——Dashboard控制面板服务]]></title><link>https://blog.csdn.net/F2001523/article/details/114444358</link><guid>https://blog.csdn.net/F2001523/article/details/114444358</guid><author>F2001523</author><pubDate>Sat, 06 Mar 2021 15:52:50 +0800</pubDate><description><![CDATA[文章目录一、OpenStack-Dashboard组件部署1. 修改local_setting本地控制台的配置文件2. 重启服务3. 验证操作
一、OpenStack-Dashboard组件部署
因为在CT控制节点已安装httpd服务，而Dashboard控制台也需要httpd支持，所以此处可以在C1节点进行安装httpd
[root@c1 ~]# yum -y install openstack-dashboard httpd

1. 修改local_setting本地控制台的配置文件
[root@c1 ]]></description><category></category></item><item><title><![CDATA[OpenStack-T版——Neutron网络服务理论+实验!]]></title><link>https://blog.csdn.net/F2001523/article/details/114370262</link><guid>https://blog.csdn.net/F2001523/article/details/114370262</guid><author>F2001523</author><pubDate>Sat, 06 Mar 2021 15:46:58 +0800</pubDate><description><![CDATA[文章目录一、Neutron网络服务简介1.Neutron网络在OpenStack中有什么作用？2.Openstack网络基础服务2.1 Neutron网络结构
一、Neutron网络服务简介
1.Neutron网络在OpenStack中有什么作用？


网络是openstack最重要的资源之一，没有网络，虚拟机将被隔离。Openstack的网络服务最主要的功能就是为虚拟机实例提供网络连接，最初由nova的一个单独模块nova-compute实现，但是nova-compute支持的网络服务有限（瓶颈问题），无]]></description><category></category></item><item><title><![CDATA[OpenStack-T版——Nova计算服务]]></title><link>https://blog.csdn.net/F2001523/article/details/114369163</link><guid>https://blog.csdn.net/F2001523/article/details/114369163</guid><author>F2001523</author><pubDate>Thu, 04 Mar 2021 15:35:54 +0800</pubDate><description><![CDATA[文章目录一、Nova计算服务简介1.什么是Nova?2.组件有哪些？3.Nova调度器的类型4.过滤器调度器调度过程5. 虚拟机实例化流程二、OpenStack-nova组件部署2.1 nova组件部署位置2.2 计算节点Nova服务配置2.2.1 创建nova数据库，并执行授权操作2.2.2 管理Nova用户及服务2.3 修改nova配置文件(nova.conf)2.4 初始化数据库2.5 启动Nova服务2.6 计算节点配置Nova服务-c1节点1.安装nova-compute组件2.修改配置文件3.开]]></description><category></category></item><item><title><![CDATA[OpenStack-T版——Placement组件部署]]></title><link>https://blog.csdn.net/F2001523/article/details/114368276</link><guid>https://blog.csdn.net/F2001523/article/details/114368276</guid><author>F2001523</author><pubDate>Thu, 04 Mar 2021 14:55:29 +0800</pubDate><description><![CDATA[文章目录一、Placement简介1.Placement提供了什么？2.需修改的配置文件1. placement.conf2. 00-placement-api.conf二、部署流程1. 创建数据库实例和数据库用户2 创建Placement服务用户和API的endpoint3. 修改 placement配置文件4. 导入数据库及修改Apache配置4.1 导入数据库4.2 修改Apache配置文件4.3 重新启动apache并测试
一、Placement简介
1.Placement提供了什么？
Placem]]></description><category></category></item><item><title><![CDATA[OpenStack-T版——Glance镜像服务理论+实验!]]></title><link>https://blog.csdn.net/F2001523/article/details/114364620</link><guid>https://blog.csdn.net/F2001523/article/details/114364620</guid><author>F2001523</author><pubDate>Thu, 04 Mar 2021 12:05:29 +0800</pubDate><description><![CDATA[文章目录一、Glance概述及配置1.简单了解Glance镜像服务1.1 什么是镜像1.2 Glance镜像在OpenStack中是什么？1.3 镜像服务1.4 一个镜像从上传到可以使用的几个状态/过程1.5 以下标识的是镜像上载完成后的状态类型1.6 访问权限1.7 glance的工作流程2.配置流程2.1 创建数据库实例和数据库用户2.2 创建用户、修改配置文件2.2.1 创建用户前，需要首先执行管理员环境变量脚本（此处已经在~/.bashrc 中定义过了）2.2.2 创建镜像服务 API 端点，Ope]]></description><category></category></item><item><title><![CDATA[OpenStack-T版——keystone认证服务+实验！]]></title><link>https://blog.csdn.net/F2001523/article/details/114347184</link><guid>https://blog.csdn.net/F2001523/article/details/114347184</guid><author>F2001523</author><pubDate>Thu, 04 Mar 2021 03:12:53 +0800</pubDate><description><![CDATA[文章目录一、keystone简介二、keystone身份服务功能三、keystone管理对象四、keystone认证流程4.1 Keystone工作流程图4.2 上图模块4.3 流程过程4.3.1 流程详细解析五、OpenStack架构的keystone组件部署六、部署keystone认证组件1. 创建数据库实例和数据库用户(在控制端上)2. 安装、配置keystone、数据库、Apache2.1 安装keystone、httpd、mod_wsgi2.2 对接mysql2.3 设置传递认证令牌的过程模式加密]]></description><category></category></item><item><title><![CDATA[OpenStack中创建消息队列用户时出现：Error: unable to connect to node rabbit@localhost: nodedown]]></title><link>https://blog.csdn.net/F2001523/article/details/113964402</link><guid>https://blog.csdn.net/F2001523/article/details/113964402</guid><author>F2001523</author><pubDate>Tue, 23 Feb 2021 00:11:38 +0800</pubDate><description><![CDATA[文章目录一、问题二、解决办法
一、问题
在安装RadditMQ结束，创建消息队列用户，用于controler和node节点连接rabbitmq的认证时出现
[root@controller ~]#  rabbitmqctl add_user openstack RABBIT_PASS
Error: unable to connect to node rabbit@localhost: nodedown    无法连接到节点rabbit

DIAGNOSTICS
===========

attempted ]]></description><category></category></item><item><title><![CDATA[OpenStack-T版——手动搭建OpenStack底层环境（rabbitmq、mariadb、memcache、Apache)）+实验！]]></title><link>https://blog.csdn.net/F2001523/article/details/113962044</link><guid>https://blog.csdn.net/F2001523/article/details/113962044</guid><author>F2001523</author><pubDate>Mon, 22 Feb 2021 23:54:26 +0800</pubDate><description><![CDATA[文章过程一、部署资源环境二、搭建思路三、搭建过程1. 部署流程1. 最小化虚拟机2. 设置网卡3. 设置免交互4. 设置时间同步5. 设置任务计划6. 安装配置MariaDB7. 安装RabbitMQ（消息队列）8. 访问OpenStack图形化页面9. 安装memcached9.1 为什么要安装memcache?9.2 介绍一下memcache9.3 安装memcached10. 安装etcd10.1 etcd特点
一、部署资源环境

二、搭建思路
1.配置操作系统
2.配置OpenStack运行环境
3]]></description><category></category></item><item><title><![CDATA[什么是OpenStack?  OpenStack核心组件之运行流程]]></title><link>https://blog.csdn.net/F2001523/article/details/113195659</link><guid>https://blog.csdn.net/F2001523/article/details/113195659</guid><author>F2001523</author><pubDate>Tue, 26 Jan 2021 21:37:53 +0800</pubDate><description><![CDATA[文章目录一、OpenStack简介1. OpenStack概述2. OpenStack服务2.1 8个核心服务2.2 8个核心组件2.3 组件的详细解释2.3.1 Nova（核心组件）（负责生命周期管理）2.3.2 Neutron（负责虚拟网络的管理）2.3.3 Keystone（全局组件）2.3.4 Horizon（Ui页面）2.3.5 Glance（镜像模板）2.3.6 Cinder(块存储)2.3.7 Swift（对象存储）2.3.8 Ceilometer（度量，监控）2.4 Keystone工作流程]]></description><category></category></item><item><title><![CDATA[什么是云计算的？云计算的定义、特征、模型分别是什么？]]></title><link>https://blog.csdn.net/F2001523/article/details/113098894</link><guid>https://blog.csdn.net/F2001523/article/details/113098894</guid><author>F2001523</author><pubDate>Sun, 24 Jan 2021 22:59:58 +0800</pubDate><description><![CDATA[文章目录一、云计算简介1.什么是云计算?2.云计算资源3.云计算的定义3.1 五种基本特征3.1.1 按需自助服务3.1.2 广泛的网络访问3.1.3 资源共享3.1.4 快速的可伸缩性3.1.5 可度量的服务3.2 三种服务模型3.2.1 软件即服务 (SaaS)3.2.2 平台即服务 (PaaS)3.2.3 架构即服务 (IaaS)3.3 四种发布模型3.3.1 私有云（使用计费）3.3.2 社区云3.3.3 公有云3.3.4 混合云（公有云，私有云）4.云计算服务模型1.IaaS（基础结构即服务）提供]]></description><category></category></item><item><title><![CDATA[Zibbix分布式系统监控——理论+实验超详细！！！]]></title><link>https://blog.csdn.net/F2001523/article/details/112855504</link><guid>https://blog.csdn.net/F2001523/article/details/112855504</guid><author>F2001523</author><pubDate>Wed, 20 Jan 2021 00:36:38 +0800</pubDate><description><![CDATA[文章目录一、zabbix简介1.什么是zibbix？2.zibbix的作用3.zibbix的组成4.zibbix的应用场景5.zibbix的特点6.zabbix主要功能7.zabbix重要组件8.监控系统运行流程二、部署zabbix监控2.1 环境2.2 监控端配置2.2.1 部署LAMP架构2.2.2 部署zabbix服务器2.3 被监控端配置2.4 服务端创建被监控主机2.5 创建监控主机的内容2.6 邮箱报警2.7 网页报警设置2.8 创建动作触发报警2.9 恢复操作2.10 监控邮箱设置测试2.11]]></description><category></category></item><item><title><![CDATA[自动化运维工具Ansible的脚本——playbook剧本]]></title><link>https://blog.csdn.net/F2001523/article/details/112853024</link><guid>https://blog.csdn.net/F2001523/article/details/112853024</guid><author>F2001523</author><pubDate>Tue, 19 Jan 2021 22:44:22 +0800</pubDate><description><![CDATA[文章目录一、playbook剧本概述1.剧本的三要素2.剧本的组成3.playbook的一些常用命令二、YAML概述2.1 什么是YAML？2.2 基本语法规则2.3 YAML支持的数据结构三、实例操作3.1 环境3.2 实操3.2.1 测试主控端与被控端的连通性性脚本3.2.2 指定远程主机sudo切换用3.2.3 安装httpd，关闭防火墙脚本3.2.4 安装apache服务并开启服务，创建测试网页，关闭防火墙3.2.5 ignore_errors忽略3.2.6 Handlers介绍3.2.6.1 示例]]></description><category></category></item></channel></rss>