组合数学靠运气

组合数学靠运气
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic Discuss
Problem Description

n 个不同糖果,放到 m 个看起来一样礼品盒里。允许盒子为空。
求可用的方案数,答案对 20170825 取模。
Input

输入两个数字 n, m(1⩽n,m⩽100)。
Output

输出答案对 20170825 取模的结果。
Example Input

4 2
Example Output

8
Hint

Author

【2016级ACM暑假集训 结训赛(算法组)】Stone

n个球,m个盒子,组合数学,第二类斯特林数。
状态转移:
dp[n][m] = m * dp[n-1][m-1] + dp[n-1][m-1];
然后枚举箱子个数,加和。

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#define Mod  20170825
using namespace std;
int main()
{
    int n, m;
        scanf("%d %d", &n, &m);
        long long int dp[234][134] = {0};
        dp[0][0] = 1;
        dp[1][1] = 1;
        for(int i=2;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                dp[i][j] = (dp[i-1][j]*j%Mod + dp[i-1][j-1]%Mod)%Mod;
            }
        }
        long long int ans = 0;
        for(int i=0;i<=m;i++)
            ans = (ans%Mod + dp[n][i]%Mod)%Mod;
        printf("%lld\n", ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值